You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
calculate-overlay/net-wireless/rtl8814au/rtl8814au-20240228.ebuild

27 lines
611 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit linux-mod-r1
COMMIT="df500c5c91397fe9239be9c4bf38ca5ca1947b43"
DESCRIPTION="Realtek 8814AU USB WiFi module for Linux kernel"
HOMEPAGE="https://github.com/morrownr/8814au"
SRC_URI="https://github.com/morrownr/8814au/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="amd64"
SLOT="0"
DEPEND="virtual/linux-sources"
S="${WORKDIR}/8814au-${COMMIT}"
src_compile() {
local modlist=( 8814au=net/wireless )
local modargs=( KSRC="${KV_OUT_DIR}" )
linux-mod-r1_src_compile
}