You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
calculate-overlay/sys-firmware/eth-firmware/eth-firmware-20181026.ebuild

35 lines
848 B

# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
MYPN=linux-firmware
MYP=linux-firmware-${PV}
GIT_COMMIT="1cb4e51018293c14642f115b5868cda92b879161"
SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${MYP}.tar.gz"
KEYWORDS="amd64 x86"
DESCRIPTION="Binary firmware for Realtek Ethernet"
HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
LICENSE="linux-firmware ( BSD ISC MIT no-source-code ) GPL-2 GPL-2+ freedist"
SLOT="0"
IUSE=""
DEPEND=""
RDEPEND="!sys-kernel/linux-firmware"
RESTRICT="binchecks strip"
src_unpack() {
default
# rename directory from git snapshot tarball
mv ${MYPN}-*/ ${P} || die
}
src_install() {
insinto /lib/firmware/
doins -r rtl_nic
}