parent
cf6db13f9f
commit
4beeea492a
@ -0,0 +1,49 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-50d-r1.ebuild,v 1.1 2015/01/18 01:44:25 patrick Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils toolchain-funcs
|
||||
|
||||
DESCRIPTION="MirBSD KSH Shell"
|
||||
HOMEPAGE="http://mirbsd.de/mksh"
|
||||
SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
|
||||
IUSE="static"
|
||||
DEPEND="static? ( dev-libs/klibc )"
|
||||
RDEPEND=""
|
||||
S="${WORKDIR}/${PN}"
|
||||
|
||||
src_compile() {
|
||||
tc-export CC
|
||||
# we want to build static with klibc
|
||||
if use static ; then
|
||||
unset CC
|
||||
export CC="/usr/bin/klcc"
|
||||
export LDSTATIC="-static"
|
||||
fi
|
||||
export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
|
||||
# we can't assume lto existing/enabled, so we add a fallback
|
||||
sh Build.sh -r -c lto || sh Rebuild.sh || die
|
||||
}
|
||||
|
||||
src_install() {
|
||||
exeinto /bin
|
||||
doexe mksh
|
||||
doman mksh.1
|
||||
dodoc dot.mkshrc
|
||||
}
|
||||
|
||||
src_test() {
|
||||
./test.sh || die
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
ebegin "Updating /etc/shells"
|
||||
( grep -v "^/bin/mksh$" "${ROOT}"etc/shells; echo "/bin/mksh" ) > "${T}"/shells
|
||||
mv -f "${T}"/shells "${ROOT}"etc/shells
|
||||
eend $?
|
||||
}
|
@ -0,0 +1,123 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.14.1-r1.ebuild,v 1.1 2015/01/18 11:35:29 pacho Exp $
|
||||
|
||||
EAPI="5"
|
||||
GCONF_DEBUG="yes"
|
||||
GNOME2_LA_PUNT="yes"
|
||||
|
||||
inherit autotools eutils gnome2
|
||||
|
||||
DESCRIPTION="Simple document viewer for GNOME"
|
||||
HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
|
||||
|
||||
LICENSE="GPL-2+ CC-BY-SA-3.0"
|
||||
# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
|
||||
SLOT="0/evd3.4-evv3.3"
|
||||
IUSE="debug djvu dvi gnome +introspection libsecret nautilus +postscript t1lib tiff xps"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
|
||||
|
||||
# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
|
||||
# not mature enough
|
||||
# atk used in libview
|
||||
# gdk-pixbuf used all over the place
|
||||
# libX11 used for totem-screensaver
|
||||
COMMON_DEPEND="
|
||||
dev-libs/atk
|
||||
>=dev-libs/glib-2.36:2
|
||||
>=dev-libs/libxml2-2.5:2
|
||||
sys-libs/zlib:=
|
||||
x11-libs/gdk-pixbuf:2
|
||||
>=x11-libs/gtk+-3.14:3[introspection?]
|
||||
gnome-base/gsettings-desktop-schemas
|
||||
>=x11-libs/cairo-1.10:=
|
||||
>=app-text/poppler-0.24:=[cairo]
|
||||
djvu? ( >=app-text/djvu-3.5.17:= )
|
||||
dvi? (
|
||||
virtual/tex-base
|
||||
dev-libs/kpathsea:=
|
||||
t1lib? ( >=media-libs/t1lib-5:= ) )
|
||||
gnome? ( gnome-base/gnome-desktop:3 )
|
||||
introspection? ( >=dev-libs/gobject-introspection-1 )
|
||||
libsecret? ( >=app-crypt/libsecret-0.5 )
|
||||
nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
|
||||
postscript? ( >=app-text/libspectre-0.2:= )
|
||||
tiff? ( >=media-libs/tiff-3.6:0= )
|
||||
xps? ( >=app-text/libgxps-0.2.1:= )
|
||||
"
|
||||
RDEPEND="${COMMON_DEPEND}
|
||||
gnome-base/librsvg
|
||||
|| (
|
||||
>=x11-themes/adwaita-icon-theme-2.17.1
|
||||
>=x11-themes/gnome-icon-theme-2.17.1
|
||||
>=x11-themes/hicolor-icon-theme-0.10 )
|
||||
x11-themes/gnome-icon-theme-symbolic
|
||||
"
|
||||
DEPEND="${COMMON_DEPEND}
|
||||
app-text/docbook-xml-dtd:4.3
|
||||
app-text/yelp-tools
|
||||
dev-util/gdbus-codegen
|
||||
>=dev-util/gtk-doc-am-1.13
|
||||
>=dev-util/intltool-0.35
|
||||
sys-devel/gettext
|
||||
virtual/pkgconfig
|
||||
"
|
||||
# eautoreconf needs:
|
||||
# app-text/yelp-tools
|
||||
|
||||
src_prepare() {
|
||||
# Disable toggle-find action for documents not supporting find (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-disable-toggle-find.patch
|
||||
|
||||
# Handle incorrect 0 resolution found in TIFF files (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-incorrect-resolution.patch
|
||||
|
||||
# Fix runtime critical warning when starting in fullscreen mode (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-critical-warning.patch
|
||||
|
||||
# configure.ac: workaround quoting issues (from '3.14')
|
||||
epatch "${FILESDIR}"/${PN}-3.14.0-non-bash-support.patch
|
||||
|
||||
# Scroll to the search result selected by user (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-scroll-search.patch
|
||||
|
||||
# Show correct page when next search result requested (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-show-correct.patch
|
||||
|
||||
# Fix configuration with ligbnome-desktop (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-gnome-desktop.patch
|
||||
|
||||
# Use correct maximum size for thumbnail images (from '3.14')
|
||||
epatch "${FILESDIR}"/${P}-thumbnail-size.patch
|
||||
|
||||
eautoreconf
|
||||
gnome2_src_prepare
|
||||
|
||||
# Do not depend on adwaita-icon-theme, bug #326855, #391859
|
||||
# https://bugs.freedesktop.org/show_bug.cgi?id=29942
|
||||
sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
|
||||
-i configure || die "sed failed"
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
gnome2_src_configure \
|
||||
--disable-static \
|
||||
--enable-pdf \
|
||||
--enable-comics \
|
||||
--enable-thumbnailer \
|
||||
--with-platform=gnome \
|
||||
--enable-dbus \
|
||||
--enable-browser-plugin \
|
||||
$(use_enable djvu) \
|
||||
$(use_enable dvi) \
|
||||
$(use_with libsecret keyring) \
|
||||
$(use_enable gnome libgnome-desktop) \
|
||||
$(use_enable introspection) \
|
||||
$(use_enable nautilus) \
|
||||
$(use_enable postscript ps) \
|
||||
$(use_enable t1lib) \
|
||||
$(use_enable tiff) \
|
||||
$(use_enable xps) \
|
||||
BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
|
||||
ITSTOOL=$(type -P true)
|
||||
}
|
@ -0,0 +1,33 @@
|
||||
From 8875003da7f78a6fbba36fcc70d6ed2d372da7a6 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||
Date: Sun, 19 Oct 2014 16:01:38 +0200
|
||||
Subject: Fix runtime critical warning when starting in fullscreen mode
|
||||
|
||||
The problem is that when running fullscreen mode we call
|
||||
ev_window_update_links_model() to update the page action widget of the
|
||||
fullscreen toolbar, but when running directly in fullscreen mode, this
|
||||
can happen before the links have been loaded in the sidebar. Since
|
||||
ev_window_update_links_model() is also called automatically when the
|
||||
links model property changes, we can simply return early in
|
||||
ev_window_update_links_model() when the model is NULL and it will be
|
||||
called again with a valid model when the links job finishes.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=737864
|
||||
|
||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||
index 4de4732..e7f6a96 100644
|
||||
--- a/shell/ev-window.c
|
||||
+++ b/shell/ev-window.c
|
||||
@@ -4024,6 +4024,9 @@ ev_window_update_links_model (EvWindow *window)
|
||||
"model", &model,
|
||||
NULL);
|
||||
|
||||
+ if (!model)
|
||||
+ return;
|
||||
+
|
||||
page_selector = ev_toolbar_get_page_selector (EV_TOOLBAR (window->priv->toolbar));
|
||||
ev_page_action_widget_update_links_model (EV_PAGE_ACTION_WIDGET (page_selector), model);
|
||||
if (window->priv->fs_toolbar) {
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,23 @@
|
||||
From bfa59b72ed0c86192ca9b1f0882ca5119aa7fe12 Mon Sep 17 00:00:00 2001
|
||||
From: Carlos Garcia Campos <carlosgc@gnome.org>
|
||||
Date: Sun, 19 Oct 2014 15:24:18 +0200
|
||||
Subject: Disable toggle-find action for documents not supporting find
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=738262
|
||||
|
||||
diff --git a/shell/ev-window.c b/shell/ev-window.c
|
||||
index c4f1f5d..4de4732 100644
|
||||
--- a/shell/ev-window.c
|
||||
+++ b/shell/ev-window.c
|
||||
@@ -502,6 +502,8 @@ ev_window_update_actions_sensitivity (EvWindow *ev_window)
|
||||
can_get_text && !recent_view_mode);
|
||||
ev_window_set_action_enabled (ev_window, "find", can_find &&
|
||||
!recent_view_mode);
|
||||
+ ev_window_set_action_enabled (ev_window, "toggle-find", can_find &&
|
||||
+ !recent_view_mode);
|
||||
ev_window_set_action_enabled (ev_window, "rotate-left", has_pages &&
|
||||
!recent_view_mode);
|
||||
ev_window_set_action_enabled (ev_window, "rotate-right", has_pages &&
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,26 @@
|
||||
From fa73b3b976a8aec415006d7fc99bab84d04650e4 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Kasik <mkasik@redhat.com>
|
||||
Date: Wed, 19 Nov 2014 10:53:29 +0100
|
||||
Subject: Fix configuration with ligbnome-desktop
|
||||
|
||||
A typo caused fail of configuration with enabled
|
||||
support for libgnome-desktop.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=733721
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index dd4bcab..0ae92b1 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -313,7 +313,7 @@ if test "$enable_gnome_desktop" != "no"; then
|
||||
PKG_CHECK_MODULES([LIBGNOME_DESKTOP], [gnome-desktop-3.0], has_libgnome_desktop=yes, has_libgnome_desktop=no)
|
||||
else
|
||||
PKG_CHECK_MODULES([LIBGNOME_DESKTOP], [gnome-desktop-3.0])
|
||||
- has_libgnome_desktop = yes
|
||||
+ has_libgnome_desktop=yes
|
||||
fi
|
||||
|
||||
if test x$has_libgnome_desktop = xyes; then
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,39 @@
|
||||
From 24a3d032728ab6cc530fab45d4eb5e232677c928 Mon Sep 17 00:00:00 2001
|
||||
From: Gabor Kelemen <kelemeng@gnome.hu>
|
||||
Date: Fri, 10 Oct 2014 11:49:26 +0200
|
||||
Subject: tiff: Handle incorrect 0 resolution found in TIFF files
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=646414
|
||||
|
||||
diff --git a/backend/tiff/tiff-document.c b/backend/tiff/tiff-document.c
|
||||
index 80ac0f5..8f40934 100644
|
||||
--- a/backend/tiff/tiff-document.c
|
||||
+++ b/backend/tiff/tiff-document.c
|
||||
@@ -172,9 +172,10 @@ tiff_document_get_resolution (TiffDocument *tiff_document,
|
||||
gfloat *x_res,
|
||||
gfloat *y_res)
|
||||
{
|
||||
- gfloat x = 72.0, y = 72.0;
|
||||
+ gfloat x = 0.0;
|
||||
+ gfloat y = 0.0;
|
||||
gushort unit;
|
||||
-
|
||||
+
|
||||
if (TIFFGetField (tiff_document->tiff, TIFFTAG_XRESOLUTION, &x) &&
|
||||
TIFFGetField (tiff_document->tiff, TIFFTAG_YRESOLUTION, &y)) {
|
||||
if (TIFFGetFieldDefaulted (tiff_document->tiff, TIFFTAG_RESOLUTIONUNIT, &unit)) {
|
||||
@@ -185,8 +186,9 @@ tiff_document_get_resolution (TiffDocument *tiff_document,
|
||||
}
|
||||
}
|
||||
|
||||
- *x_res = x;
|
||||
- *y_res = y;
|
||||
+ /* Handle 0 values: some software set TIFF resolution as `0 , 0` see bug #646414 */
|
||||
+ *x_res = x > 0 ? x : 72.0;
|
||||
+ *y_res = y > 0 ? y : 72.0;
|
||||
}
|
||||
|
||||
static void
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,35 @@
|
||||
From aa988afb009307c6b854b5da366d34e0ee2ea763 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Kasik <mkasik@redhat.com>
|
||||
Date: Mon, 19 May 2014 14:32:19 +0200
|
||||
Subject: Scroll to the search result selected by user
|
||||
|
||||
Scroll to page on which is the search result selected by user
|
||||
when not in continuous mode.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=730252
|
||||
|
||||
diff --git a/libview/ev-view.c b/libview/ev-view.c
|
||||
index 5ed2d78..f3aa033 100644
|
||||
--- a/libview/ev-view.c
|
||||
+++ b/libview/ev-view.c
|
||||
@@ -8158,6 +8158,9 @@ jump_to_find_page (EvView *view, EvViewFindDirection direction, gint shift)
|
||||
break;
|
||||
}
|
||||
}
|
||||
+
|
||||
+ if (!view->continuous)
|
||||
+ ev_document_model_set_page (view->model, view->find_page);
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -8282,6 +8285,7 @@ ev_view_find_set_result (EvView *view, gint page, gint result)
|
||||
{
|
||||
view->find_page = page;
|
||||
view->find_result = result;
|
||||
+ jump_to_find_page (view, EV_VIEW_FIND_NEXT, 0);
|
||||
jump_to_find_result (view);
|
||||
gtk_widget_queue_draw (GTK_WIDGET (view));
|
||||
}
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,38 @@
|
||||
From f2c908cf8a8f8d5d0fbed1bc0871c8bdb531f751 Mon Sep 17 00:00:00 2001
|
||||
From: Marek Kasik <mkasik@redhat.com>
|
||||
Date: Tue, 18 Nov 2014 12:53:40 +0100
|
||||
Subject: Show correct page when next search result requested
|
||||
|
||||
If there are more than 1 results on a page then requesting
|
||||
next search result from the same page will not return you
|
||||
to the page with the search results if you moved from the
|
||||
page in the meantime (when you are not in continuous mode).
|
||||
This applies also to previous results.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=730252
|
||||
|
||||
diff --git a/libview/ev-view.c b/libview/ev-view.c
|
||||
index f3aa033..a9159cd 100644
|
||||
--- a/libview/ev-view.c
|
||||
+++ b/libview/ev-view.c
|
||||
@@ -8250,6 +8250,8 @@ ev_view_find_next (EvView *view)
|
||||
if (view->find_result >= n_results) {
|
||||
view->find_result = 0;
|
||||
jump_to_find_page (view, EV_VIEW_FIND_NEXT, 1);
|
||||
+ } else if (view->find_page != view->current_page) {
|
||||
+ jump_to_find_page (view, EV_VIEW_FIND_NEXT, 0);
|
||||
}
|
||||
|
||||
jump_to_find_result (view);
|
||||
@@ -8264,6 +8266,8 @@ ev_view_find_previous (EvView *view)
|
||||
if (view->find_result < 0) {
|
||||
jump_to_find_page (view, EV_VIEW_FIND_PREV, -1);
|
||||
view->find_result = MAX (0, ev_view_find_get_n_results (view, view->find_page) - 1);
|
||||
+ } else if (view->find_page != view->current_page) {
|
||||
+ jump_to_find_page (view, EV_VIEW_FIND_PREV, 0);
|
||||
}
|
||||
|
||||
jump_to_find_result (view);
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -0,0 +1,23 @@
|
||||
From 1820802ff261d1ca05acd3c3153918c0fd1c686f Mon Sep 17 00:00:00 2001
|
||||
From: Sebastian Keller <sebastian-keller@gmx.de>
|
||||
Date: Sat, 29 Nov 2014 03:46:27 +0100
|
||||
Subject: thumbnailer: Use correct maximum size for thumbnail images
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=740877
|
||||
|
||||
diff --git a/thumbnailer/evince-thumbnailer.c b/thumbnailer/evince-thumbnailer.c
|
||||
index 1649252..998447d 100644
|
||||
--- a/thumbnailer/evince-thumbnailer.c
|
||||
+++ b/thumbnailer/evince-thumbnailer.c
|
||||
@@ -177,7 +177,7 @@ evince_thumbnail_pngenc_get (EvDocument *document, const char *thumbnail, int si
|
||||
|
||||
ev_document_get_page_size (document, 0, &width, &height);
|
||||
|
||||
- rc = ev_render_context_new (page, 0, size / width);
|
||||
+ rc = ev_render_context_new (page, 0, size / MAX (height, width));
|
||||
pixbuf = ev_document_get_thumbnail (document, rc);
|
||||
g_object_unref (rc);
|
||||
g_object_unref (page);
|
||||
--
|
||||
cgit v0.10.1
|
||||
|
@ -1,46 +0,0 @@
|
||||
# Copyright 1999-2014 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r1.ebuild,v 1.19 2014/11/16 18:15:00 ago Exp $
|
||||
|
||||
EAPI=2
|
||||
USE_RUBY="ruby19"
|
||||
|
||||
RUBY_FAKEGEM_TASK_DOC=""
|
||||
RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
|
||||
|
||||
inherit ruby-fakegem
|
||||
|
||||
DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML"
|
||||
HOMEPAGE="http://github.com/rtomayko/ronn/"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
|
||||
|
||||
IUSE=""
|
||||
|
||||
ruby_add_rdepend "
|
||||
>=dev-ruby/hpricot-0.8.2
|
||||
>=dev-ruby/mustache-0.7.0
|
||||
>=dev-ruby/rdiscount-1.5.8"
|
||||
|
||||
all_ruby_prepare() {
|
||||
# Avoid test failing due to changes in hash handling in ruby 1.8.7:
|
||||
# https://github.com/rtomayko/ronn/issues/56
|
||||
sed -i -e '81 s:^:#:' test/test_ronn.rb || die
|
||||
}
|
||||
|
||||
each_ruby_prepare() {
|
||||
# Make sure that we always use the right interpreter during tests.
|
||||
sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
|
||||
}
|
||||
|
||||
all_ruby_compile() {
|
||||
PATH="${S}/bin:${PATH}" rake man || die
|
||||
}
|
||||
|
||||
all_ruby_install() {
|
||||
all_fakegem_install
|
||||
|
||||
doman man/ronn.1 man/ronn-format.7
|
||||
}
|
@ -1,4 +1,6 @@
|
||||
DIST scala-1.2.0.1.tar.bz2 4548508 SHA256 975d6e10febf5d52a3f2d826afa7f98ddbec0a6f05eaf6c30a3f27a472ca84b9 SHA512 8fd4958e1603b576cb73f7372a88a7b06c1432e4f8a0fa6a987aa4397343c6d859ddda9972af039e0b4b1ea722dbbbfd4df03fe2edf9cc54bbc72e5cebbf200b WHIRLPOOL dfa5d71b39ffa1012d66ac8bcc281562182af13ec642fceee2e1fb7f3228a303a198a401e0578e3aad7d7608a26ae6e11978042fd488b4503ffb144e5d2efa44
|
||||
DIST scala-2.11.4.tgz 26509669 SHA256 000f5a19de78049bc06e33ee98063c7ad3cfd51212df92a8a164af89aeef8084 SHA512 f963279cba5d2f4d41d195f80dad32bf529bc5f2c3d306ce6c1b9fbb6d4977a481796d98c3d1758f3987824880ab0925ac72e3a70e4165faf7c7985e64cece28 WHIRLPOOL a76a97854e0d4ac9f2f555ab3b5196d473e8723c88926163f88c891ac31cacb7d97acadf437aee101b2d9db0fc0295f4b3fc95c5db6bc16de8e6ff54b1a2ecda
|
||||
EBUILD scala-bin-1.2.0.1.ebuild 1460 SHA256 c8e4b2b860b5bc8f64c4e88063719862900914eba80f6e19f28deaab5db64029 SHA512 bfbd26744bdf89b3388dffd690f97148f7b9a46bb68733577419a83c81bcab79423e45ebcbbd9988d1b66d95dd50f92e04841e2a6cbbd2bc6770799ba76cea7d WHIRLPOOL 117d23760fd46c6ebdd66a0b937fa48020754d86220d79d0ea2ae98c48e131500a4f5ff3236f96df5401591bece3ba72bfe7ae8dbf4b3566102170be3231a0a0
|
||||
MISC ChangeLog 1916 SHA256 abf34034d9cbe8308afca9db65aa9df2f383bb164bacd8a47731e00bd97e7067 SHA512 0ddf38cf7c604c31e04e44dbfa87e1da82d593be0886aab8c6e186086162fab52beaf256b7bad1e5856aa6f0b274cfbb2afe5629b70144bfc24229a36c95f256 WHIRLPOOL 0746eb1661027e2dcf82886a5307ba3bc1715ab25f821c8ad55325a01bb272685d1ba7b4672a03c085649fa72c4fb6656eea3bb37f87fae2cea20c5c777ef51c
|
||||
EBUILD scala-bin-2.11.4.ebuild 1870 SHA256 c4d488f3be929294ef78e18db5307e1fe86526c229de94699326dfc63c920782 SHA512 9f45f4cb11974ee6de5ace62bc027265d26ca1d47f256b74cff942d49b1a93b8a5ab257cf77b8c38afbe3ed6933d24b8e1d28d8d02917ff87eb7917c9dab5331 WHIRLPOOL ac31409f8545809c70f1bedb8d3f8cf2a2d27ba4f7e5240a568d04296f45fbacd2cf835da706c0793a3fd12934fa7a84d942140f10bf7b00d535ecbc2d41d195
|
||||
MISC ChangeLog 2056 SHA256 0fbd1f80a2c1ae1754bd1803ec62e383afac1542e825ec560fee25cae4958650 SHA512 eb23a1050b76fb89fd5079d9045ab5b9da3bcf2b5589b3e8ade3e944f1c4d83fcb517716f936b9108a7fdefe4d15f51079db8e72d0f95485067eaecfc22fd3b2 WHIRLPOOL c9ee35d861c70ef688e4826ee14d4f928bc68b67e639b2801654e0ff92e7a8a1e5ecb47d5bf23733f749ff6e7e3e6d84f8d4ca6b3c67c2965e83910bb53e453f
|
||||
MISC metadata.xml 159 SHA256 da2aaa3223c5418688dfbba6f899648c5bcb2e4610126519a1a862913c4f8fa6 SHA512 f5bc77a4e168cdb5a9f9c347f6f437b16bd28978351ec692d4f7e406ba93479424e2272de70fe85d2e0668172de8ccd3aa096f49d5912ed91d17bea11756865b WHIRLPOOL b0cba2d5917cc20d7409ccfedc345ab38c71df76c5c030df578d6db718f8a60dcfc1927c20e7062fafc62e955a90ec9f21cdcef6d7a566fddf374ce766ca64cc
|
||||
|
@ -0,0 +1,73 @@
|
||||
# Copyright 1999-2015 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-java/scala-bin/scala-bin-2.11.4.ebuild,v 1.1 2015/01/18 01:05:53 monsieurp Exp $
|
||||
EAPI=5
|
||||
|
||||
inherit java-utils-2
|
||||
|
||||
DESCRIPTION="The Scala Programming Language"
|
||||
HOMEPAGE="http://scala.epfl.ch/"
|
||||
SRC_URI="http://downloads.typesafe.com/scala/${PV}/scala-${PV}.tgz"
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~x86 ~amd64"
|
||||
IUSE=""
|
||||
DEPEND=""
|
||||
|
||||
RDEPEND=">=virtual/jre-1.6
|
||||
!dev-lang/scala"
|
||||
|
||||
S=${WORKDIR}/scala-${PV}
|
||||
|
||||
src_prepare() {
|
||||
ebegin 'Cleaning .bat files'
|
||||
rm -f bin/*.bat
|
||||
eend $?
|
||||
|
||||
ebegin 'Patching SCALA_HOME variable in bin/ scripts'
|
||||
for f in bin/*; do
|
||||
sed -i -e 's#\(SCALA_HOME\)=.*#\1=/usr/share/scala-bin#' $f
|
||||
done
|
||||
eend $?
|
||||
}
|
||||
|
||||
src_install() {
|
||||
ebegin 'Installing bin scripts'
|
||||
dodir /usr/bin
|
||||
exeinto /usr/bin
|
||||
doexe bin/*
|
||||
eend $?
|
||||
|
||||
ebegin 'Installing jar files'
|
||||
cd lib/
|
||||
|
||||
# Unversion those libs
|
||||
java-pkg_newjar scala-continuations-library_*.jar scala-continuations-library.jar
|
||||
java-pkg_newjar akka-actor_*.jar akka-actor.jar
|
||||
java-pkg_newjar config-*.jar config.jar
|
||||
java-pkg_newjar scala-actors-2.11.0.jar scala-actors.jar
|
||||
java-pkg_newjar scala-actors-migration_*.jar scala-actors-migration.jar
|
||||
java-pkg_newjar scala-swing_*.jar scala-swing.jar
|
||||
java-pkg_newjar scala-parser-combinators_*.jar scala-parser-combinators.jar
|
||||
java-pkg_newjar scala-xml_*.jar scala-xml.jar
|
||||
java-pkg_newjar jline-*.jar jline.jar
|
||||
java-pkg_newjar scala-continuations-plugin_*.jar scala-continuations-plugin.jar
|
||||
java-pkg_newjar scalap-*.jar scalap.jar
|
||||
|
||||
# Install these the usual way
|
||||
java-pkg_dojar scala-compiler.jar
|
||||
java-pkg_dojar scala-library.jar
|
||||
java-pkg_dojar scala-reflect.jar
|
||||
|
||||
eend $?
|
||||
|
||||
cd ../
|
||||
|
||||
ebegin 'Installing man pages'
|
||||
doman man/man1/*.1
|
||||
eend $?
|
||||
|
||||
ebegin 'Installing documentation'
|
||||
java-pkg_dohtml -r doc/tools
|
||||
eend $?
|
||||
}
|
Some files were not shown because too many files have changed in this diff Show More
Loading…
Reference in new issue