parent
d5d755ee56
commit
62eaf4338b
@ -1,6 +1,6 @@
|
||||
DIST emelfm2-0.9.1.tar.bz2 1217126 SHA256 bfb94ff4e40c0a9c0d2a6aeb0efa22e177accbf6abd3096226d93daecd23642f SHA512 bd3a1ad2338c80d6824a2a84736470ecfa7e93f455cc8e3243944833807fe9b3544e2fea6bd6ccbddaf0188ad89ce616ed146271f6ffabec80f5dfb2f1ad6f57 WHIRLPOOL 4eaa1d95396a23c5f00ef66784f9f124f8c79e5dfe820f8bc556037109d799f5b1d30ef25a51183116ba955c931c0ec161d0e8aa3d92b79f33f0baaba7edf21d
|
||||
EBUILD emelfm2-0.9.1-r1.ebuild 1978 SHA256 e24c682ea40f08eb20c67f401b8acfb5e254a86e5df0db7e2073f19b774763f7 SHA512 58fde4ca37268daa5d11e6abf9f384146f9770c4cdf5a947cdf5e73f45ffb5818c59d0530a8b93560015ae25a237eacb5bb7b6248d88a9e8dceb46cfff33d57d WHIRLPOOL 1386ade9ae28d62d8ac8363d5019264c5abd1f1432ac6846deda863fc9bda4983e24438193ebf1ba3b1997be51226630666aa9cc49232c20d62fa8cb544e26da
|
||||
EBUILD emelfm2-0.9.1-r2.ebuild 2026 SHA256 a656a9e76d24f48f8afecc3ddd096e9c17c2dc257db4ef1ea7fad39154ac3e21 SHA512 861b0bb2e45b21fca31c077a8699c7545bdfbce7fb2d79df7f8ad01f9f958a27ebf337d428532b37b93a9503785063354f13ff147cab2e8b615ce5673a138764 WHIRLPOOL e4d260f3832599aa16ef12e4c10177827a5df38acafc5fd58598bef83026965c0d4689072075cdd2db30d16504ffe2ddc47102006ea8dd54b1c2d9175d57e9d7
|
||||
MISC ChangeLog 3740 SHA256 0e48ff15aa9d06f2406b8d877515f6d1d59bf94a997765f9ac3f957ce6501ab9 SHA512 6ab58952652b5f1604dbeb1b1c759dcc763ce6a18eca221249341732ea064ba2a66756bedda9f2e2fba693b58a7de2b8be458de91fe11f025e7f76fe1e2249e3 WHIRLPOOL a52cdaa4e474d21c11f324d25bc3629fd397189783084b4f1df0fb110e96f618431d13be8c5575d1516ca39e0ba8cd1cc1d07d35f2548e21bd6e64ae37a7f2a8
|
||||
MISC ChangeLog 4082 SHA256 fbd47502cdb5466314afee1046b039bda7eb6c2d4a15e937f8a18a9ff6d8ebfa SHA512 02487474cbd1b8822561ad193e29ab53b84025fbe417fd8dfd554940846debb39aea2c7811bf1e8f7b79f82427b78a867bc0765dc91bccf2f0f3f32262badf18 WHIRLPOOL c39f78a88095f21140a65f2233121df7149154fced70a50d77afcfac06fe2b6738f52e9da3d3821923438ffa85f5e749e1a735b1ae065d84dc1f5fbea331d64d
|
||||
MISC ChangeLog-2015 6611 SHA256 14a5e06730a76a911633e58c0ed07554686ecde9646e551d42ddf637f433fe75 SHA512 12b38479a99f1ce0a1e4609901835e2e5560f14399018dba14017949b0f5a583d2d053079c25fe64a003f79b6c8daa6660edb50ca7e2aa978c8e9277fb004f66 WHIRLPOOL 3669c8b06e3302e58b781393c1da0653d8fe4e235226172b35b21a6112b9e9d8b5f58eab9e72040fc097677cb0fdbc62b0820e2a92e6feac70296c32d1f5f595
|
||||
MISC metadata.xml 472 SHA256 4b81ae24eba65347f30ea82b093e747138b520c054ae2ba225d748a290d5013a SHA512 7f388f3867a249b22c8fbf0508f31219ca77fe0c445195d5791b26ff85ac78de4eb0050ad9ee7bfbfa6639b54005a659ab164572c102d8308d64a1f19f69e2aa WHIRLPOOL e35e3930d25b7ac68d2d793d9c32479462f5c2a1593f0204e4f3c861253c14d25a2abb3a2d5a5d5e461d3bd8e66f9afc4800f73c00cdac9ca8bc4ba832d47a9f
|
||||
|
@ -0,0 +1,35 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
JAVA_PKG_IUSE="source"
|
||||
|
||||
inherit eutils java-pkg-2 java-ant-2
|
||||
|
||||
MY_A="apache-${P}-src"
|
||||
MY_P="${MY_A/-servlet-api/}"
|
||||
DESCRIPTION="Tomcat's Servlet API 3.0/JSP API 2.2 implementation"
|
||||
HOMEPAGE="http://tomcat.apache.org/"
|
||||
SRC_URI="mirror://apache/tomcat/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="3.0"
|
||||
KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
|
||||
IUSE=""
|
||||
|
||||
DEPEND=">=virtual/jdk-1.6"
|
||||
RDEPEND=">=virtual/jre-1.6"
|
||||
|
||||
S="${WORKDIR}/${MY_P}/"
|
||||
|
||||
java_prepare() {
|
||||
cp "${FILESDIR}/${SLOT}-build.xml" build.xml || die "Could not replace build.xml"
|
||||
rm -fR */*/build.xml ||die
|
||||
java-pkg_clean
|
||||
}
|
||||
|
||||
src_install() {
|
||||
java-pkg_dojar "${S}"/output/build/lib/*.jar
|
||||
use source && java-pkg_dosrc java/javax/servlet/
|
||||
}
|
@ -1,4 +1,4 @@
|
||||
DIST metasm-1.0.2.gem 746496 SHA256 075f63f78e02b02fac991c3e2cc2c2c12b31a3d2ac580ffa66ba2a6e6c3c966f SHA512 b5f90e46be0d3b86c2b525823aa1fc1ea711a8abe9edaf2908af73d869e1f6dc5163f45ea20bd1034b0f10b17c25e7b7cd9af6a77ebfbf24d925a68a84d264e3 WHIRLPOOL 229fd1f8b80025b4fbf67fefe095e8815eb6cf1ab1d01985e8444dad9bda32cfb8da6953cf4937caa8496a77ebd4d4a3d6bd7d6fdfa56008b57c1010bff45bbd
|
||||
EBUILD metasm-1.0.2-r3.ebuild 1454 SHA256 705a2b87f1927805096de9be26c10cb2b03e47d6bd82982298a1a9a8c8f37097 SHA512 8903644faf47a4f594c029312a6b3b2334022987d5a358901d467849b7c22b2419ed54fd85f3791b72dab51b4a58da623627ac5a427b872a20d42e4953efca83 WHIRLPOOL 11ab7f35cac002c62a501723bf8c5fd58b7cea95c88ee5e9e13f59c086cdb428ff5c913cc29519e84987777e1d5c17edca76f5f598ac7b3e99a5b9dc8989ee1a
|
||||
MISC ChangeLog 975 SHA256 14e93ab4663b1268be5ba278902179d27b06a04da5a91c2bc3d7338f4a5f1ca5 SHA512 c96134d0f7f94f2e41b38522dd4be9da77780ebac2c931eb5d4ccf62bb60086ba71634eff67c0c9c2c87f50b759bd114a43707fba8c2d275bc98be309c8c3d9e WHIRLPOOL 49a0da7f1dafe9121fc8eb04b122dbaaca269c46e59c92e0cbfd864c8e2d61c8b78d360ee16f0b5c633067b30ba5520d6f7f9227992b29f7bdec7f590e6496db
|
||||
MISC ChangeLog 1222 SHA256 4e3bf2340effe461342c300b04ca7868993a31d9e50a773e9b703ee9facc443e SHA512 7bc421d44a7a87533cdbf480714f071ccd78f2b98ea9de62f6b8fd21ad48f0d803d454bd2a3e8d75b36e3d73d90cdd921834b555d09b5b9fcd27b5a4ff41470d WHIRLPOOL 098856d9e2354f690cd4d3a88a4a38c4a02092a6ce7a24ac713282d42b8095d954d8676b361106823dc8b4e4609d5d181e0ccde82f2798c0740053db484a0a45
|
||||
MISC metadata.xml 300 SHA256 178b9e17007bb7dd5e8e9c8d43dd77930f28d825caea504951a7dfbb34434190 SHA512 d034ba4e52ce5b5cf83b2799064196a060457f28a18cac84f6b43f1be4d1d3739f3e0c32a178ab65b9dfafdec9ea8b8b223c717c92e74f0bf8164d8098aeb94e WHIRLPOOL 98e69849825a031c09e27ea6ac8f405bd0810b7bb65f98a0911012a1883348c171ffcfa2fcf9230fbfe67cf9076528a18756190a5b84cd5e7acab2ec70cb05cd
|
||||
|
@ -1 +1 @@
|
||||
Tue, 21 Jun 2016 08:40:46 +0000
|
||||
Tue, 21 Jun 2016 11:10:45 +0000
|
||||
|
@ -1 +1 @@
|
||||
Tue, 21 Jun 2016 08:40:46 +0000
|
||||
Tue, 21 Jun 2016 11:10:45 +0000
|
||||
|
@ -0,0 +1,13 @@
|
||||
DEFINED_PHASES=compile configure install preinst prepare setup
|
||||
DEPEND=>=virtual/jdk-1.6 >=dev-java/java-config-2.2.0-r3 source? ( app-arch/zip ) >=dev-java/ant-core-1.8.2:0 >=dev-java/javatoolkit-0.3.0-r2
|
||||
DESCRIPTION=Tomcat's Servlet API 3.0/JSP API 2.2 implementation
|
||||
EAPI=5
|
||||
HOMEPAGE=http://tomcat.apache.org/
|
||||
IUSE=elibc_FreeBSD source elibc_FreeBSD
|
||||
KEYWORDS=~amd64 ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris
|
||||
LICENSE=Apache-2.0
|
||||
RDEPEND=>=virtual/jre-1.6 >=dev-java/java-config-2.2.0-r3 source? ( app-arch/zip )
|
||||
SLOT=3.0
|
||||
SRC_URI=mirror://apache/tomcat/tomcat-7/v7.0.70/src/apache-tomcat-7.0.70-src.tar.gz
|
||||
_eclasses_=eutils 792f83d5ec9536cb5ccef375469d8bde java-ant-2 7c5d0c274d390745f5033754a319f515 java-pkg-2 b02dc1e46b3648e467b5fbdf7857cf28 java-utils-2 9a25f292ff66f8c2c00100ac0b15c54f multilib d062ae4ba2fc40a19c11de2ad89b6616 toolchain-funcs c9d9187f4caa4026a0ceddd8dfceb3c1 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=1f7ece82a9f85f19d4d2a1b2c2d71138
|
@ -0,0 +1,13 @@
|
||||
DEFINED_PHASES=compile configure install prepare setup test
|
||||
DEPEND=!static? ( >=dev-libs/boost-1.49[threads] dev-libs/crypto++ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl ) upnp? ( net-libs/miniupnpc ) ) static? ( >=dev-libs/boost-1.49[static-libs,threads] dev-libs/crypto++[static-libs] !libressl? ( dev-libs/openssl:0[-bindist,static-libs] ) libressl? ( dev-libs/libressl[static-libs] ) upnp? ( net-libs/miniupnpc[static-libs] ) ) i2p-hardening? ( >=sys-devel/gcc-4.7 ) || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 ) virtual/pkgconfig sys-devel/make >=dev-util/cmake-2.8.12
|
||||
DESCRIPTION=A C++ daemon for accessing the I2P anonymous network
|
||||
EAPI=6
|
||||
HOMEPAGE=https://github.com/PurpleI2P/i2pd
|
||||
IUSE=cpu_flags_x86_aes i2p-hardening libressl pch static +upnp
|
||||
KEYWORDS=~amd64 ~arm ~x86
|
||||
LICENSE=GPL-2
|
||||
RDEPEND=!static? ( >=dev-libs/boost-1.49[threads] dev-libs/crypto++ !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl ) upnp? ( net-libs/miniupnpc ) )
|
||||
SLOT=0
|
||||
SRC_URI=https://github.com/PurpleI2P/i2pd/archive/2.8.0.tar.gz -> i2pd-2.8.0.tar.gz
|
||||
_eclasses_=cmake-utils ac5bd012586c6cf0d9826400d9de2830 eutils 792f83d5ec9536cb5ccef375469d8bde flag-o-matic d270fa247153df66074f795fa42dba3e multilib d062ae4ba2fc40a19c11de2ad89b6616 systemd 3165c885f3c71ffae7a867d931fb0e07 toolchain-funcs c9d9187f4caa4026a0ceddd8dfceb3c1 user 906f3c8eb3a2350a4f1191a89baa3e46 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=3425755471ebc35fd306fc0ce6733d7f
|
@ -1,14 +0,0 @@
|
||||
DEFINED_PHASES=compile install postinst postrm preinst setup test unpack
|
||||
DEPEND=!build? ( sys-apps/sed >=sys-devel/binutils-2.11.90.0.31 ) deblob? ( || ( >=dev-lang/python-2.7.5-r2:2.7 ) )
|
||||
DESCRIPTION=Hardened kernel sources (kernel series 4.5)
|
||||
EAPI=5
|
||||
HOMEPAGE=http://www.gentoo.org/proj/en/hardened/
|
||||
IUSE=deblob symlink build deblob
|
||||
KEYWORDS=~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86
|
||||
LICENSE=GPL-2 !deblob? ( freedist )
|
||||
RDEPEND=>=sys-devel/gcc-4.5 !build? ( >=sys-libs/ncurses-5.2 sys-devel/make dev-lang/perl sys-devel/bc )
|
||||
RESTRICT=binchecks strip
|
||||
SLOT=4.5.7-r1
|
||||
SRC_URI=mirror://kernel/linux/kernel/v4.x/linux-4.5.tar.xz deblob? ( http://www.fsfla.org/svn/fsfla/software/linux-libre/releases/tags/4.5-gnu/deblob-4.5 http://www.fsfla.org/svn/fsfla/software/linux-libre/releases/tags/4.5-gnu/deblob-check -> deblob-check-4.5 ) http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-4.5.7-2.extras.tar.bz2 mirror://gentoo/genpatches-4.5-9.base.tar.xz
|
||||
_eclasses_=eutils 792f83d5ec9536cb5ccef375469d8bde kernel-2 42f76647114dfe0b91855624a26b2cc2 multilib d062ae4ba2fc40a19c11de2ad89b6616 python-any-r1 1c20f9b800324335a8e3b137363362e8 python-utils-r1 c0ed2a2f233d3af6dd556048695dc5cb toolchain-funcs c9d9187f4caa4026a0ceddd8dfceb3c1 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=78c4f860214a4e2ba198073d19aaaccf
|
@ -1,14 +0,0 @@
|
||||
DEFINED_PHASES=compile install postinst postrm preinst setup test unpack
|
||||
DEPEND=!build? ( sys-apps/sed >=sys-devel/binutils-2.11.90.0.31 ) deblob? ( || ( >=dev-lang/python-2.7.5-r2:2.7 ) )
|
||||
DESCRIPTION=Hardened kernel sources (kernel series 4.5)
|
||||
EAPI=5
|
||||
HOMEPAGE=http://www.gentoo.org/proj/en/hardened/
|
||||
IUSE=deblob symlink build deblob
|
||||
KEYWORDS=~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86
|
||||
LICENSE=GPL-2 !deblob? ( freedist )
|
||||
RDEPEND=>=sys-devel/gcc-4.5 !build? ( >=sys-libs/ncurses-5.2 sys-devel/make dev-lang/perl sys-devel/bc )
|
||||
RESTRICT=binchecks strip
|
||||
SLOT=4.5.7-r2
|
||||
SRC_URI=mirror://kernel/linux/kernel/v4.x/linux-4.5.tar.xz deblob? ( http://www.fsfla.org/svn/fsfla/software/linux-libre/releases/tags/4.5-gnu/deblob-4.5 http://www.fsfla.org/svn/fsfla/software/linux-libre/releases/tags/4.5-gnu/deblob-check -> deblob-check-4.5 ) http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-4.5.7-3.extras.tar.bz2 mirror://gentoo/genpatches-4.5-9.base.tar.xz
|
||||
_eclasses_=eutils 792f83d5ec9536cb5ccef375469d8bde kernel-2 42f76647114dfe0b91855624a26b2cc2 multilib d062ae4ba2fc40a19c11de2ad89b6616 python-any-r1 1c20f9b800324335a8e3b137363362e8 python-utils-r1 c0ed2a2f233d3af6dd556048695dc5cb toolchain-funcs c9d9187f4caa4026a0ceddd8dfceb3c1 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=9c2a8c17205f33c78f8734395253c187
|
@ -0,0 +1,14 @@
|
||||
DEFINED_PHASES=compile configure install postinst preinst prepare setup test
|
||||
DEPEND=dev-java/eclipse-ecj:4.5 dev-java/tomcat-servlet-api:3.0 websockets? ( >=virtual/jdk-1.7 ) !websockets? ( >=virtual/jdk-1.6 ) test? ( dev-java/ant-junit:0 ) >=dev-java/java-config-2.2.0-r3 source? ( app-arch/zip ) >=dev-java/ant-core-1.8.2:0 >=dev-java/javatoolkit-0.3.0-r2
|
||||
DESCRIPTION=Tomcat Servlet-3.0/JSP-2.2 Container
|
||||
EAPI=5
|
||||
HOMEPAGE=http://tomcat.apache.org/
|
||||
IUSE=extra-webapps websockets elibc_FreeBSD doc source test elibc_FreeBSD
|
||||
KEYWORDS=~amd64 ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris
|
||||
LICENSE=Apache-2.0
|
||||
RDEPEND=dev-java/eclipse-ecj:4.5 dev-java/tomcat-servlet-api:3.0 websockets? ( >=virtual/jre-1.7 ) !websockets? ( >=virtual/jre-1.6 ) !<dev-java/tomcat-native-1.1.24 >=dev-java/java-config-2.2.0-r3 source? ( app-arch/zip )
|
||||
RESTRICT=test
|
||||
SLOT=7
|
||||
SRC_URI=mirror://apache/tomcat/tomcat-7/v7.0.70/src/apache-tomcat-7.0.70-src.tar.gz
|
||||
_eclasses_=eutils 792f83d5ec9536cb5ccef375469d8bde java-ant-2 7c5d0c274d390745f5033754a319f515 java-pkg-2 b02dc1e46b3648e467b5fbdf7857cf28 java-utils-2 9a25f292ff66f8c2c00100ac0b15c54f multilib d062ae4ba2fc40a19c11de2ad89b6616 prefix e7f2b9c6e57342e5d25eac22fce23062 toolchain-funcs c9d9187f4caa4026a0ceddd8dfceb3c1 user 906f3c8eb3a2350a4f1191a89baa3e46 versionator 99ae9d758cbe7cfed19170e7d48f5a9c
|
||||
_md5_=27ca17b91df99495fc4092c23b134b5e
|
@ -1 +1 @@
|
||||
Tue, 21 Jun 2016 08:40:46 +0000
|
||||
Tue, 21 Jun 2016 11:10:45 +0000
|
||||
|
@ -1 +1 @@
|
||||
Tue Jun 21 08:39:51 UTC 2016
|
||||
Tue Jun 21 11:09:50 UTC 2016
|
||||
|
@ -1 +1 @@
|
||||
Tue, 21 Jun 2016 09:30:01 +0000
|
||||
Tue, 21 Jun 2016 11:30:01 +0000
|
||||
|
@ -1 +1 @@
|
||||
1466498401 Tue 21 Jun 2016 08:40:01 AM UTC
|
||||
1466507401 Tue 21 Jun 2016 11:10:01 AM UTC
|
||||
|
@ -1 +1 @@
|
||||
Tue, 21 Jun 2016 08:40:46 +0000
|
||||
Tue, 21 Jun 2016 11:10:45 +0000
|
||||
|
@ -0,0 +1,99 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=6
|
||||
inherit eutils systemd user cmake-utils
|
||||
|
||||
DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
|
||||
HOMEPAGE="https://github.com/PurpleI2P/i2pd"
|
||||
SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm ~x86"
|
||||
IUSE="cpu_flags_x86_aes i2p-hardening libressl pch static +upnp"
|
||||
|
||||
RDEPEND="!static? ( >=dev-libs/boost-1.49[threads]
|
||||
dev-libs/crypto++
|
||||
!libressl? ( dev-libs/openssl:0 )
|
||||
libressl? ( dev-libs/libressl )
|
||||
upnp? ( net-libs/miniupnpc )
|
||||
)"
|
||||
DEPEND="${RDEPEND}
|
||||
static? ( >=dev-libs/boost-1.49[static-libs,threads]
|
||||
dev-libs/crypto++[static-libs]
|
||||
!libressl? ( dev-libs/openssl:0[-bindist,static-libs] )
|
||||
libressl? ( dev-libs/libressl[static-libs] )
|
||||
upnp? ( net-libs/miniupnpc[static-libs] ) )
|
||||
i2p-hardening? ( >=sys-devel/gcc-4.7 )
|
||||
|| ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )"
|
||||
|
||||
I2PD_USER=i2pd
|
||||
I2PD_GROUP=i2pd
|
||||
|
||||
CMAKE_USE_DIR="${S}/build"
|
||||
|
||||
DOCS=( README.md docs/i2pd.conf debian/tunnels.conf debian/subscriptions.txt )
|
||||
|
||||
src_prepare() {
|
||||
eapply "${FILESDIR}/${PN}-2.5.1-fix_installed_components.patch"
|
||||
eapply_user
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
mycmakeargs=(
|
||||
-DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
|
||||
-DWITH_HARDENING=$(usex i2p-hardening ON OFF)
|
||||
-DWITH_PCH=$(usex pch ON OFF)
|
||||
-DWITH_STATIC=$(usex static ON OFF)
|
||||
-DWITH_UPNP=$(usex upnp ON OFF)
|
||||
-DWITH_LIBRARY=ON
|
||||
-DWITH_BINARY=ON
|
||||
)
|
||||
cmake-utils_src_configure
|
||||
}
|
||||
|
||||
src_install() {
|
||||
cmake-utils_src_install
|
||||
|
||||
# config
|
||||
insinto /etc/i2pd
|
||||
doins docs/i2pd.conf
|
||||
doins debian/tunnels.conf
|
||||
doins debian/subscriptions.txt
|
||||
|
||||
# grant i2pd group read and write access to config files
|
||||
fowners "root:${I2PD_GROUP}" \
|
||||
/etc/i2pd/i2pd.conf \
|
||||
/etc/i2pd/tunnels.conf \
|
||||
/etc/i2pd/subscriptions.txt
|
||||
fperms 660 \
|
||||
/etc/i2pd/i2pd.conf \
|
||||
/etc/i2pd/tunnels.conf \
|
||||
/etc/i2pd/subscriptions.txt
|
||||
|
||||
# working directory
|
||||
keepdir /var/lib/i2pd
|
||||
insinto /var/lib/i2pd
|
||||
doins -r contrib/certificates
|
||||
dosym /etc/i2pd/subscriptions.txt /var/lib/i2pd/subscriptions.txt
|
||||
fowners "${I2PD_USER}:${I2PD_GROUP}" /var/lib/i2pd/
|
||||
fperms 700 /var/lib/i2pd/
|
||||
|
||||
# add /var/lib/i2pd/certificates to CONFIG_PROTECT
|
||||
doenvd "${FILESDIR}/99i2pd"
|
||||
|
||||
# openrc and systemd daemon routines
|
||||
newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
|
||||
newinitd "${FILESDIR}/i2pd-2.6.0-r3.initd" i2pd
|
||||
systemd_newunit "${FILESDIR}/i2pd-2.6.0-r3.service" i2pd.service
|
||||
|
||||
# logrotate
|
||||
insinto /etc/logrotate.d
|
||||
newins "${FILESDIR}/i2pd-2.6.0-r3.logrotate" i2pd
|
||||
}
|
||||
|
||||
pkg_setup() {
|
||||
enewgroup "${I2PD_GROUP}"
|
||||
enewuser "${I2PD_USER}" -1 -1 /var/lib/run/i2pd "${I2PD_GROUP}"
|
||||
}
|
@ -1,45 +0,0 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
|
||||
ETYPE="sources"
|
||||
K_WANT_GENPATCHES="base"
|
||||
K_GENPATCHES_VER="9"
|
||||
K_DEBLOB_AVAILABLE="1"
|
||||
|
||||
inherit kernel-2
|
||||
detect_version
|
||||
|
||||
HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
|
||||
HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
|
||||
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
|
||||
|
||||
UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
|
||||
UNIPATCH_EXCLUDE="
|
||||
1500_XATTR_USER_PREFIX.patch
|
||||
2900_dev-root-proc-mount-fix.patch"
|
||||
|
||||
DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
|
||||
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
|
||||
IUSE="deblob"
|
||||
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
|
||||
|
||||
RDEPEND=">=sys-devel/gcc-4.5"
|
||||
|
||||
pkg_postinst() {
|
||||
kernel-2_pkg_postinst
|
||||
|
||||
local GRADM_COMPAT="sys-apps/gradm-3.1*"
|
||||
|
||||
ewarn
|
||||
ewarn "Users of grsecurity's RBAC system must ensure they are using"
|
||||
ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
|
||||
ewarn "It is strongly recommended that the following command is issued"
|
||||
ewarn "prior to booting a ${PF} kernel for the first time:"
|
||||
ewarn
|
||||
ewarn "emerge -na =${GRADM_COMPAT}"
|
||||
ewarn
|
||||
}
|
@ -1,45 +0,0 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="5"
|
||||
|
||||
ETYPE="sources"
|
||||
K_WANT_GENPATCHES="base"
|
||||
K_GENPATCHES_VER="9"
|
||||
K_DEBLOB_AVAILABLE="1"
|
||||
|
||||
inherit kernel-2
|
||||
detect_version
|
||||
|
||||
HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
|
||||
HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
|
||||
SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
|
||||
|
||||
UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
|
||||
UNIPATCH_EXCLUDE="
|
||||
1500_XATTR_USER_PREFIX.patch
|
||||
2900_dev-root-proc-mount-fix.patch"
|
||||
|
||||
DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
|
||||
HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
|
||||
IUSE="deblob"
|
||||
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
|
||||
|
||||
RDEPEND=">=sys-devel/gcc-4.5"
|
||||
|
||||
pkg_postinst() {
|
||||
kernel-2_pkg_postinst
|
||||
|
||||
local GRADM_COMPAT="sys-apps/gradm-3.1*"
|
||||
|
||||
ewarn
|
||||
ewarn "Users of grsecurity's RBAC system must ensure they are using"
|
||||
ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
|
||||
ewarn "It is strongly recommended that the following command is issued"
|
||||
ewarn "prior to booting a ${PF} kernel for the first time:"
|
||||
ewarn
|
||||
ewarn "emerge -na =${GRADM_COMPAT}"
|
||||
ewarn
|
||||
}
|
@ -0,0 +1,149 @@
|
||||
diff -Naur apache-tomcat-7.0.63-src.orig/build.xml apache-tomcat-7.0.63-src/build.xml
|
||||
--- apache-tomcat-7.0.63-src.orig/build.xml 2015-06-30 09:15:44.000000000 +0100
|
||||
+++ apache-tomcat-7.0.63-src/build.xml 2015-08-22 21:13:12.453038827 +0100
|
||||
@@ -660,12 +660,14 @@
|
||||
</fileset>
|
||||
</copy>
|
||||
<!-- Copy JSP Schemas and DTDs to be packed into servlet-api.jar -->
|
||||
+<!--
|
||||
<copy todir="${tomcat.classes}/javax/servlet/resources" encoding="ISO-8859-1">
|
||||
<fileset dir="${tomcat.classes}/javax/servlet/jsp/resources">
|
||||
<include name="*" />
|
||||
<exclude name="jspxml*" />
|
||||
</fileset>
|
||||
</copy>
|
||||
+-->
|
||||
|
||||
</target>
|
||||
|
||||
@@ -721,26 +723,32 @@
|
||||
manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
|
||||
|
||||
<!-- Servlet 3.0 Implementation JAR File -->
|
||||
+<!--
|
||||
<jarIt jarfile="${servlet-api.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.servlet-api"
|
||||
manifest="${tomcat.manifests}/servlet-api.jar.manifest"
|
||||
notice="${tomcat.manifests}/servlet-api.jar.notice"
|
||||
license="${tomcat.manifests}/servlet-api.jar.license" />
|
||||
+-->
|
||||
|
||||
<!-- JSP 2.2 Implementation JAR File -->
|
||||
+<!--
|
||||
<jarIt jarfile="${jsp-api.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.jsp-api"
|
||||
manifest="${tomcat.manifests}/jsp-api.jar.manifest"
|
||||
notice="${tomcat.manifests}/jsp-api.jar.notice"
|
||||
license="${tomcat.manifests}/jsp-api.jar.license" />
|
||||
+-->
|
||||
|
||||
<!-- JSP 2.2 EL Implementation JAR File -->
|
||||
+<!--
|
||||
<jarIt jarfile="${el-api.jar}"
|
||||
filesDir="${tomcat.classes}"
|
||||
filesId="files.el-api"
|
||||
manifest="${tomcat.manifests}/el-api.jar.manifest" />
|
||||
+-->
|
||||
|
||||
<!-- Bootstrap JAR File -->
|
||||
<jarIt jarfile="${bootstrap.jar}"
|
||||
@@ -986,12 +994,14 @@
|
||||
<target name="deploy" depends="package,build-docs,compile-webapp-examples"
|
||||
description="Default. Builds a working Tomcat instance">
|
||||
|
||||
+<!--
|
||||
<copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
|
||||
file="${tomcat-native.tar.gz}" />
|
||||
<copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
|
||||
file="${commons-daemon.native.src.tgz}" />
|
||||
|
||||
<copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
|
||||
+-->
|
||||
|
||||
<!-- Copy scripts -->
|
||||
<copy todir="${tomcat.build}/bin">
|
||||
@@ -1051,14 +1061,15 @@
|
||||
<exclude name="${jdt.jar.filename}"/>
|
||||
</fileset>
|
||||
</delete>
|
||||
+<!--
|
||||
<copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
|
||||
-
|
||||
+-->
|
||||
<!-- Add sources for examples -->
|
||||
<antcall target="examples-sources" />
|
||||
-
|
||||
+<!--
|
||||
<copy file="${tomcat-dbcp.jar}" todir="${tomcat.build}/lib"
|
||||
failonerror="false"/>
|
||||
-
|
||||
+-->
|
||||
<!-- build the jdbc-pool jar and source jar-->
|
||||
<echo message="Building Tomcat JDBC pool libraries"/>
|
||||
<ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
|
||||
@@ -1681,7 +1692,7 @@
|
||||
|
||||
<target name="extras-webservices-prepare"
|
||||
depends="extras-prepare"
|
||||
- description="Prepare to build web services extras package">
|
||||
+ description="Prepare to build web services extras package" unless="noget">
|
||||
|
||||
<antcall target="downloadfile">
|
||||
<param name="sourcefile" value="${jaxrpc-lib.loc}"/>
|
||||
@@ -1886,6 +1897,7 @@
|
||||
description="Create the Tomcat javadoc" >
|
||||
<fail unless="java.7.home"
|
||||
message="The java.7.home property must be set for javadoc build"/>
|
||||
+<!--
|
||||
<javadoc packagenames="javax.servlet.*"
|
||||
excludepackagenames="javax.servlet.jsp.*"
|
||||
sourcepath="${tomcat.dist}/src/java"
|
||||
@@ -1947,6 +1959,7 @@
|
||||
<path location="${ant.core.lib}"/>
|
||||
</classpath>
|
||||
</javadoc>
|
||||
+-->
|
||||
<javadoc packagenames="javax.websocket.*"
|
||||
sourcepath="${tomcat.dist}/src/java"
|
||||
destdir="${tomcat.dist}/webapps/docs/websocketapi"
|
||||
@@ -1985,9 +1998,11 @@
|
||||
<path refid="tomcat.webservices.classpath"/>
|
||||
<path location="${ant.core.lib}"/>
|
||||
</classpath>
|
||||
+<!--
|
||||
<link href="../servletapi"/>
|
||||
<link href="../jspapi"/>
|
||||
<link href="../elapi"/>
|
||||
+-->
|
||||
<link href="../websocketapi"/>
|
||||
<link href="http://docs.oracle.com/javase/7/docs/api/"/>
|
||||
<link href="http://commons.apache.org/proper/commons-io/javadocs/api-release/"/>
|
||||
@@ -2642,7 +2657,7 @@
|
||||
</target>
|
||||
|
||||
<target name="download-compile"
|
||||
- description="Download (and build) components necessary to compile" >
|
||||
+ description="Download (and build) components necessary to compile" unless="noget">
|
||||
|
||||
<antcall target="downloadfile-2">
|
||||
<param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
|
||||
@@ -2699,7 +2714,7 @@
|
||||
</target>
|
||||
|
||||
<target name="download-test-compile"
|
||||
- description="Download additional components for the tests" >
|
||||
+ description="Download additional components for the tests" unless="noget">
|
||||
|
||||
<antcall target="downloadfile">
|
||||
<param name="sourcefile" value="${junit.loc}"/>
|
||||
@@ -2727,7 +2742,7 @@
|
||||
</target>
|
||||
|
||||
<target name="download-dist"
|
||||
- description="Download additional components for a distribution" >
|
||||
+ description="Download additional components for a distribution" unless="noget">
|
||||
|
||||
<antcall target="downloadzip-2">
|
||||
<param name="sourcefile.1" value="${tomcat-native.win.1}"/>
|
@ -0,0 +1,145 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI=5
|
||||
|
||||
JAVA_PKG_IUSE="doc source test"
|
||||
|
||||
inherit eutils java-pkg-2 java-ant-2 prefix user
|
||||
|
||||
MY_P="apache-${P}-src"
|
||||
|
||||
DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
|
||||
HOMEPAGE="http://tomcat.apache.org/"
|
||||
SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="7"
|
||||
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
|
||||
IUSE="extra-webapps websockets"
|
||||
|
||||
RESTRICT="test" # can we run them on a production system?
|
||||
|
||||
ECJ_SLOT="4.5"
|
||||
SAPI_SLOT="3.0"
|
||||
|
||||
COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
|
||||
dev-java/tomcat-servlet-api:${SAPI_SLOT}"
|
||||
RDEPEND="${COMMON_DEP}
|
||||
websockets? ( >=virtual/jre-1.7 )
|
||||
!websockets? ( >=virtual/jre-1.6 )
|
||||
!<dev-java/tomcat-native-1.1.24"
|
||||
DEPEND="${COMMON_DEP}
|
||||
websockets? ( >=virtual/jdk-1.7 )
|
||||
!websockets? ( >=virtual/jdk-1.6 )
|
||||
test? ( dev-java/ant-junit:0 )"
|
||||
|
||||
S=${WORKDIR}/${MY_P}
|
||||
|
||||
pkg_setup() {
|
||||
java-pkg-2_pkg_setup
|
||||
enewgroup tomcat 265
|
||||
enewuser tomcat 265 -1 /dev/null tomcat
|
||||
}
|
||||
|
||||
java_prepare() {
|
||||
# Remove bundled servlet-api
|
||||
rm -rv java/javax/{el,servlet} || die
|
||||
|
||||
java-pkg_clean
|
||||
|
||||
epatch "${FILESDIR}/${P}-build.xml.patch"
|
||||
|
||||
# For use of catalina.sh in netbeans
|
||||
sed -i -e "/^# ----- Execute The Requested Command/ a\
|
||||
CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
|
||||
bin/catalina.sh || die
|
||||
}
|
||||
|
||||
JAVA_ANT_REWRITE_CLASSPATH="true"
|
||||
|
||||
EANT_BUILD_TARGET="deploy"
|
||||
EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
|
||||
EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
|
||||
EANT_NEEDS_TOOLS="true"
|
||||
EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
|
||||
|
||||
# revisions of the scripts
|
||||
IM_REV="-r1"
|
||||
INIT_REV="-r1"
|
||||
|
||||
src_compile() {
|
||||
use websockets && EANT_EXTRA_ARGS+=" -Djava.7.home=${JAVA_HOME}"
|
||||
EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
|
||||
java-pkg-2_src_compile
|
||||
}
|
||||
|
||||
src_test() {
|
||||
java-pkg-2_src_test
|
||||
}
|
||||
|
||||
src_install() {
|
||||
local dest="/usr/share/${PN}-${SLOT}"
|
||||
|
||||
java-pkg_jarinto "${dest}"/bin
|
||||
java-pkg_dojar output/build/bin/*.jar
|
||||
exeinto "${dest}"/bin
|
||||
doexe output/build/bin/*.sh
|
||||
|
||||
java-pkg_jarinto "${dest}"/lib
|
||||
java-pkg_dojar output/build/lib/*.jar
|
||||
|
||||
dodoc RELEASE-NOTES RUNNING.txt
|
||||
use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
|
||||
use source && java-pkg_dosrc java/*
|
||||
|
||||
### Webapps ###
|
||||
|
||||
insinto "${dest}"/webapps
|
||||
doins -r output/build/webapps/{host-manager,manager,ROOT}
|
||||
use extra-webapps && doins -r output/build/webapps/{docs,examples}
|
||||
|
||||
### Config ###
|
||||
|
||||
# create "logs" directory in $CATALINA_BASE
|
||||
# and set correct perms, see #458890
|
||||
dodir "${dest}"/logs
|
||||
fperms 0750 "${dest}"/logs
|
||||
|
||||
# replace the default pw with a random one, see #92281
|
||||
local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
|
||||
sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
|
||||
|
||||
# prepend gentoo.classpath to common.loader, see #453212
|
||||
sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
|
||||
|
||||
insinto "${dest}"
|
||||
doins -r output/build/conf
|
||||
|
||||
### rc ###
|
||||
|
||||
cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
|
||||
eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
|
||||
sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
|
||||
|
||||
insinto "${dest}"/gentoo
|
||||
doins "${T}"/tomcat.conf
|
||||
exeinto "${dest}"/gentoo
|
||||
newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
|
||||
newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
|
||||
elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
|
||||
elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
|
||||
|
||||
elog "To manage Tomcat instances, run:"
|
||||
elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
|
||||
|
||||
ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
|
||||
ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
|
||||
|
||||
# einfo "Please read https://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
|
||||
}
|
Loading…
Reference in new issue