parent
eb2828f075
commit
d98f3171af
@ -0,0 +1,51 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/haskell-updater-1.2.0.10-r1.ebuild,v 1.1 2013/09/03 20:09:18 slyfox Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
CABAL_FEATURES="bin nocabaldep"
|
||||
inherit eutils haskell-cabal
|
||||
|
||||
DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
|
||||
HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
|
||||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
|
||||
IUSE=""
|
||||
|
||||
DEPEND=">=dev-lang/ghc-6.12.1"
|
||||
|
||||
# Need a lower version for portage to get --keep-going
|
||||
RDEPEND="|| ( >=sys-apps/portage-2.1.6
|
||||
sys-apps/pkgcore
|
||||
sys-apps/paludis )"
|
||||
|
||||
src_prepare() {
|
||||
if use prefix; then
|
||||
sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
|
||||
"${S}/Distribution/Gentoo/Packages.hs" || die
|
||||
|
||||
sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
|
||||
"${S}/Distribution/Gentoo/GHC.hs" || die
|
||||
fi
|
||||
|
||||
# for ghc snapshots (usually come with unstable Cabal API)
|
||||
cabal_chdeps \
|
||||
'Cabal >= 1.8 && < 1.17' 'Cabal >= 1.8 && < 1.18' \
|
||||
'process < 1.2' 'process < 1.3'
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
cabal_src_configure \
|
||||
--bindir="${EPREFIX}/usr/sbin" \
|
||||
--constraint="Cabal == $(cabal-version)"
|
||||
}
|
||||
|
||||
src_install() {
|
||||
cabal_src_install
|
||||
|
||||
dodoc TODO
|
||||
}
|
@ -1,25 +0,0 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-admin/haskell-updater/haskell-updater-1.2.0.10.ebuild,v 1.1 2013/09/03 10:04:50 qnikst Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
# ebuild generated by hackport 0.3.3.9999
|
||||
|
||||
CABAL_FEATURES="bin"
|
||||
inherit haskell-cabal
|
||||
|
||||
DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
|
||||
HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
|
||||
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
|
||||
IUSE=""
|
||||
|
||||
RDEPEND=""
|
||||
DEPEND="${RDEPEND}
|
||||
>=dev-haskell/cabal-1.8 <dev-haskell/cabal-1.17
|
||||
>=dev-lang/ghc-6.10.4
|
||||
"
|
@ -0,0 +1,110 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/phoronix-test-suite/phoronix-test-suite-4.8.1.ebuild,v 1.1 2013/09/04 08:10:05 patrick Exp $
|
||||
|
||||
EAPI=4
|
||||
|
||||
inherit eutils bash-completion-r1
|
||||
|
||||
DESCRIPTION="Phoronix's comprehensive, cross-platform testing and benchmark suite"
|
||||
HOMEPAGE="http://www.phoronix-test-suite.com"
|
||||
SRC_URI="http://www.phoronix-test-suite.com/download.php?file=${P} -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-3"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND=""
|
||||
|
||||
# php 5.3 doesn't have pcre and reflection useflags anymore
|
||||
RDEPEND="dev-lang/php[cli,curl,gd,json,posix,pcntl,truetype,zip]
|
||||
dev-php/pecl-ps"
|
||||
|
||||
S="${WORKDIR}/${PN}"
|
||||
|
||||
src_prepare() {
|
||||
sed -i -e "s,export PTS_DIR=\`pwd\`,export PTS_DIR=\"/usr/share/${PN}\"," \
|
||||
phoronix-test-suite
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
:
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
:
|
||||
}
|
||||
|
||||
src_install() {
|
||||
dodir /usr/share/${PN}
|
||||
insinto /usr/share/${PN}
|
||||
|
||||
doman documentation/man-pages/phoronix-test-suite.1
|
||||
dodoc AUTHORS CHANGE-LOG
|
||||
dohtml -r documentation/
|
||||
doicon pts-core/static/images/phoronix-test-suite.png
|
||||
doicon pts-core/static/images/openbenchmarking.png
|
||||
domenu pts-core/static/phoronix-test-suite.desktop
|
||||
rm -f pts-core/static/phoronix-test-suite.desktop
|
||||
|
||||
doins -r pts-core
|
||||
exeinto /usr/bin
|
||||
doexe phoronix-test-suite
|
||||
|
||||
fperms a+x /usr/share/${PN}/pts-core/static/scripts/root-access.sh
|
||||
fperms a+x /usr/share/${PN}/pts-core/external-test-dependencies/scripts/install-gentoo-packages.sh
|
||||
|
||||
dobashcompletion pts-core/static/bash_completion ${PN}
|
||||
|
||||
# Need to fix the cli-php config for downloading to work. Very naughty!
|
||||
local slots
|
||||
local slot
|
||||
if [[ "x${PHP_TARGETS}" == "x" ]] ; then
|
||||
ewarn
|
||||
ewarn "PHP_TARGETS seems empty, php.ini file can't be configure."
|
||||
ewarn "Make sure that PHP_TARGETS in /etc/make.conf is set."
|
||||
ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
|
||||
ewarn "for downloading to work properly."
|
||||
ewarn
|
||||
else
|
||||
for slot in ${PHP_TARGETS}; do
|
||||
slots+=" ${slot/-/.}"
|
||||
done
|
||||
fi
|
||||
|
||||
for slot in ${slots}; do
|
||||
local PHP_INI_FILE="/etc/php/cli-${slot}/php.ini"
|
||||
if [[ -f ${PHP_INI_FILE} ]] ; then
|
||||
dodir $(dirname ${PHP_INI_FILE})
|
||||
cp ${PHP_INI_FILE} "${D}${PHP_INI_FILE}"
|
||||
sed -e 's|^allow_url_fopen .*|allow_url_fopen = On|g' -i "${D}${PHP_INI_FILE}"
|
||||
else
|
||||
if [[ "x$(eselect php show cli)" == "x${slot}" ]] ; then
|
||||
ewarn
|
||||
ewarn "${slot} hasn't a php.ini file."
|
||||
ewarn "phoronix-test-suite needs the 'allow_url_fopen' option set to \"On\""
|
||||
ewarn "for downloading to work properly."
|
||||
ewarn "Check that your PHP_INI_VERSION is set during ${slot} merge"
|
||||
ewarn
|
||||
else
|
||||
elog
|
||||
elog "${slot} hasn't a php.ini file."
|
||||
elog "phoronix-test-suite may need the 'allow_url_fopen' option set to \"On\""
|
||||
elog "for downloading to work properly if you switch to ${slot}"
|
||||
elog "Check that your PHP_INI_VERSION is set during ${slot} merge"
|
||||
elog
|
||||
fi
|
||||
fi
|
||||
done
|
||||
|
||||
ewarn
|
||||
ewarn "If you upgrade from phoronix-test-suite-2*, you should reinstall all"
|
||||
ewarn "your tests because"
|
||||
ewarn " \$HOME/.phoronix-test-suite/installed-tests/\$TEST_NAME/"
|
||||
ewarn "moves to"
|
||||
ewarn " \$HOME/.phoronix-test-suite/installed-tests/pts/\$TEST_NAME-\$TEST_VERSION/"
|
||||
ewarn "in phoronix-test-suite-3* version. The \$TEST_VERSION can be find in"
|
||||
ewarn "pts-install.xml file."
|
||||
ewarn
|
||||
}
|
@ -0,0 +1,28 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/elixir-0.10.2.ebuild,v 1.1 2013/09/03 22:55:04 hasufell Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit multilib
|
||||
|
||||
DESCRIPTION="Elixir programming language"
|
||||
HOMEPAGE="http://elixir-lang.org"
|
||||
SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0 ErlPL-1.1"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND=">=dev-lang/erlang-16"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
src_compile() {
|
||||
emake Q=""
|
||||
}
|
||||
|
||||
src_install() {
|
||||
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="/usr" install
|
||||
dodoc README.md CHANGELOG.md CONTRIBUTING.md
|
||||
}
|
@ -0,0 +1,33 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-0.11.12.ebuild,v 1.1 2013/09/03 22:57:24 hasufell Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
inherit eutils autotools
|
||||
|
||||
DESCRIPTION="A new platform layer for Node"
|
||||
HOMEPAGE="https://github.com/joyent/libuv"
|
||||
SRC_URI="https://github.com/joyent/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD BSD-2 ISC MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="static-libs"
|
||||
|
||||
src_prepare() {
|
||||
echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
|
||||
> m4/libuv-extra-automake-flags.m4 || die
|
||||
|
||||
eautoreconf
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
econf \
|
||||
$(use_enable static-libs static)
|
||||
}
|
||||
|
||||
src_install() {
|
||||
default
|
||||
prune_libtool_files
|
||||
}
|
@ -0,0 +1,75 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.7.3.ebuild,v 1.1 2013/09/03 21:34:20 aballier Exp $
|
||||
|
||||
EAPI="5"
|
||||
|
||||
inherit eutils findlib
|
||||
|
||||
MY_P=${P/_beta/test}
|
||||
DESCRIPTION="Modules for OCaml application-level Internet protocols"
|
||||
HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
|
||||
SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
|
||||
|
||||
LICENSE="ZLIB GPL-2+"
|
||||
SLOT="0/${PV}"
|
||||
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
|
||||
IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
|
||||
RESTRICT="installsources"
|
||||
|
||||
# the auth-dh compile flag has been disabled as well, since it depends on
|
||||
# ocaml-cryptgps, which is not available.
|
||||
|
||||
DEPEND=">=dev-ml/findlib-1.0
|
||||
pcre? ( >=dev-ml/pcre-ocaml-5:= )
|
||||
>=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
|
||||
cryptokit? ( dev-ml/cryptokit:= )
|
||||
gtk? ( >=dev-ml/lablgtk-2:= )
|
||||
ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
|
||||
zip? ( dev-ml/camlzip:= )
|
||||
"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
S=${WORKDIR}/${MY_P}
|
||||
|
||||
ocamlnet_use_with() {
|
||||
if use $1; then
|
||||
echo "-with-$2"
|
||||
else
|
||||
echo "-without-$2"
|
||||
fi
|
||||
}
|
||||
|
||||
ocamlnet_use_enable() {
|
||||
if use $1; then
|
||||
echo "-enable-$2"
|
||||
else
|
||||
echo "-disable-$2"
|
||||
fi
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
./configure \
|
||||
-bindir /usr/bin \
|
||||
-datadir /usr/share/${PN} \
|
||||
$(ocamlnet_use_enable cryptokit crypto) \
|
||||
$(ocamlnet_use_enable gtk gtk2) \
|
||||
$(ocamlnet_use_enable pcre pcre) \
|
||||
$(ocamlnet_use_enable ssl ssl) \
|
||||
$(ocamlnet_use_enable tk tcl) \
|
||||
$(ocamlnet_use_enable zip zip) \
|
||||
$(ocamlnet_use_with httpd nethttpd) \
|
||||
|| die "Error : econf failed!"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
emake -j1 all
|
||||
if use ocamlopt; then
|
||||
emake -j1 opt
|
||||
fi
|
||||
}
|
||||
|
||||
src_install() {
|
||||
export STRIP_MASK="*/bin/*"
|
||||
findlib_src_install
|
||||
}
|
@ -1,18 +1,26 @@
|
||||
-----BEGIN PGP SIGNED MESSAGE-----
|
||||
Hash: SHA256
|
||||
Hash: SHA512
|
||||
|
||||
DIST File-Slurp-9999.13.tar.gz 26403 SHA256 bb053bfcca0986958de1cf8a120250b25ed40ae2aaf17c5527fe9c1d098cb3e5 SHA512 7905c1f4711aefda1a7c6ea469622a1bed9d442ba45c3736dea8563ad5c849a50892bff867702f1bd1172963983e07c9ba630a1cba7afcd2cbe1481213a654f6 WHIRLPOOL 4fe54e8e845f3608a8ac6f909c7239c412a368a47c4e6ab2c9dfb7d2371074e41415c392ec848505eb12ce62cbd3be653589ba2108ca56cea51b162b53acbf38
|
||||
DIST File-Slurp-9999.19.tar.gz 39927 SHA256 ce29ebe995097ebd6e9bc03284714cdfa0c46dc94f6b14a56980747ea3253643 SHA512 3fb8f452d625e321e77475cbc7d5672d53fe49945581561a0001be0a9464e67659303271648e102d52b6ebd04c87afc7432238fcade0c098f584f3b58c90ec82 WHIRLPOOL 09d96df2241fe81a6fc4998112eabfdf6d6e2e7da178cb42bcfb34b1eaab9bd56f3a1210e15511be9970138af4cb20191fb81eb31b8e84a7a4c5d0ad88ab69a0
|
||||
EBUILD File-Slurp-9999.13.ebuild 673 SHA256 82db4ad4fa8085134a2c545e1bf320b08fdb4ec92466ba39ed1ef102dcec38fe SHA512 d0d6b9d12907269da9134ee56ba7d17088cf5529e7d26302987bd34808d7b4e0af93842504d6d35f0580dfc4b044ff16fe16065ae4c3a57a55587468d163beff WHIRLPOOL c3fbcc59a4b5fc6c2b522705e7c3b743f0e68fca839142b6a5ce1bbdcb04b5704d4421b687c7f7d6ab6dc3630e7ec92415b4b90fc14d270902ca0db23fc50a4c
|
||||
EBUILD File-Slurp-9999.190.0.ebuild 592 SHA256 5bd55136d153b582d1f57d52a760c1e2d4af9ab4c1249e6aefed6f9ad1dc391d SHA512 57ccbb2ce83541de7798997aba3ed542d2920b8520403e41c0173607aa4d84ffb18264dbd278506575d783ff3e7db2542c392f20ba8c273db97da275add7d19a WHIRLPOOL 256d5aca51349e5887453243c950d8455b7da284e8e81ea3fc947f6bfe751f0a328d65f265d7a0609c16ca5e508d2086141dc8166809bd8c974038811dfbcbeb
|
||||
MISC ChangeLog 7067 SHA256 6aebb67f3213b7441392ca2a4fd3639bdea80b2cbc158d18d8e1377b7203490d SHA512 9ca2d43a739d9973fa013d347e92b771ab50632ae65d2560b708e172247c5f06f206ac48610e5cf571dbe7ff8ffc37b26cfc51686c4a9ec03fa2d23fa8f3d517 WHIRLPOOL e7a87695a886c99280a76e394a48f924588198a0cafa61afaebd5061f72ff6e33ab613f240295b4162269b4d777961466274ed82a5b1e17215a0c0d2a74bcd8a
|
||||
EBUILD File-Slurp-9999.190.0.ebuild 587 SHA256 a595e2f7a6090d3797a14dee1e894d78a75555fc098462ad1d911ce55805fc14 SHA512 ebaf94b7cf7f8f977c3f53a9f4b2684c87d1ba389238b5d8e2b1da7a1163ab9eef8bd76ad26b8f7279be0298e5cf34d5fe95a87f5f8f5780f9e5828854033144 WHIRLPOOL 09c055c65b23eafb5bd695ce6e1dbdea99453f37fcbcb769d56560a57e32d03d55e3ae421f2ba8a10245cbce5737dfaed670a647f1a1c6eedcf3ef7e336d4315
|
||||
MISC ChangeLog 7177 SHA256 f4ead856a525b787ca8e3bcc648242ff2a260ba8187434738cbcf9962b50ec8c SHA512 c9b8b0277359e94a59e1a2bd0b4f37246ef8fdc7fc5f17d76e74e04abb2db074a3efd913b59ba38ed728de377085324931468969efc36d6d7f3753830ecf96b8 WHIRLPOOL d0754c59282107956ef0a20ede66bcfb6e3279662f2b20ebbcc33a0c0a2475b80dfc5201ad1da9c1f356dc870ae502447dff8e6b855eedb614445ab1a6c0069e
|
||||
MISC metadata.xml 353 SHA256 c92a933b9b5345bd1db188f87c0577afd686bdcf433985c2ae9fd70ff8527d2d SHA512 dae8096274e468f0a6b61c58f4e3b1fcb3d425bae574b012fb03b3b86a816dd1c3cd5ef1759b6419c83b3a1724781539bd3203cf6d5e5336433b7f08fcc02a66 WHIRLPOOL 2f2fdf20e2ea8b46e01300b471da9059719a261357fb8cf34df0ef2261b811b13040097c8c90965eb4ff789b952ba5c5674ebbdd2a9a981cb5236f441d19e342
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.21 (GNU/Linux)
|
||||
Version: GnuPG v2.0.20 (GNU/Linux)
|
||||
|
||||
iJwEAQEIAAYFAlImIxsACgkQG9wOWsQutdYHPgP8Cxua5Rk+m8+7+GIZ3NiLTBDU
|
||||
cyLn4Je9vBJPtpglnVJ/C0Qjbmcs0Fna+jXouIDRz85mzyH+5UFXC+rrtRb0VguJ
|
||||
S7P9YrgYUCsOaYERCV3uNeuDUtWn++sJOpnIJ1Glx4M3PrnuAGOHn+WHXzqgWgJU
|
||||
4HqSaI9ChGZiI7plRrs=
|
||||
=78x8
|
||||
iQIcBAEBCgAGBQJSJt/hAAoJELp701BxlEWfKfEP/1yn/qMJzpNjwGkNlLe9kCHe
|
||||
sr9FjXWVUCuxyV6hi3G7P+Q9yD+Qvz85XwwZW0KVcLq6spnUkYMRy5rX7oorcRWa
|
||||
rYF7RADCiWpBvNUij2UefqxPo43CWiqpS/2trBu8NBSBnKgU+1gYSCg0JQRy/b6C
|
||||
dNSZfHtHYVanrztQMQNQbKeEEGDH4tg3K1UockvIguFQgy75CFZHbWrPhQsvTBKH
|
||||
8i/x3T7Xa5ihhJPkJ2d1y/cbLCYIKcSmvOhnrIrPijDY0aL4jemeXG/bLP7bueyJ
|
||||
EHVnAYobshGhkiTYBecxJT8morsGRJHd5+bGqRLsktA6MrG1EWpwvYao/PSmmj7s
|
||||
0YFRpR0CmAyBPF3CttvGDWfMbCpZ7n6Qo67GyI/jwMlxMbtWMwwp3HKbIZiI8+FH
|
||||
GejADqDqDDwP7TpwH1inXiB146jcI2YkVN++JeQlIfqgcS1+2rcbfIOaM553TL+V
|
||||
WhId8YNX3ycO0fWmpGYySREVieGUlPdWrHFFA1cYX+uHgF6GxY0ebGy2n4AMLgua
|
||||
CwDQxw/JSjuTEaezCDTsWqN+qW3zD8ayCMER8tlIMmgYAje9kBpMubSZ6ENGdivz
|
||||
MiVhBHVdgvF+2ifl83KrvMHh5eqNpjkIdQDZUGqiohwYWK/nLAl6zj7+e4U5dkP/
|
||||
emcIQ+bMvosIURDZAcAc
|
||||
=+9nz
|
||||
-----END PGP SIGNATURE-----
|
||||
|
@ -0,0 +1,9 @@
|
||||
# ChangeLog for dev-python/bjoern
|
||||
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-python/bjoern/ChangeLog,v 1.1 2013/09/04 08:34:55 patrick Exp $
|
||||
|
||||
*bjoern-1.3.2 (04 Sep 2013)
|
||||
|
||||
04 Sep 2013; Patrick Lauer <patrick@gentoo.org> +bjoern-1.3.2.ebuild,
|
||||
+metadata.xml:
|
||||
Initial import, ebuild by me
|
@ -0,0 +1,4 @@
|
||||
DIST bjoern-1.3.2.tar.gz 25878 SHA256 bb272517760897a96b3fbf0564236a4f9e0e14e05d8cdcc5f9ac2957ff0c89c0 SHA512 f96ab7f6bfdd158da398c56555a47944f30ac505ed3cb8610a3fc12fe15d5a7bbb0cdba27c858e5ccac28213504b2c68aefd0c252591e3e4d63ce70c8ac840cc WHIRLPOOL 1121cc2088686532dca96b3db4116272c162b23c327a33335763237a45fd1b12a9b0e16b5f4e901fdd162ad923238f7637b29d3190ba6fb6538cb46cd809be83
|
||||
EBUILD bjoern-1.3.2.ebuild 611 SHA256 a804a1be954c7adb3c038b079e518d47e02733b9bce8f233638594ff51ec1d5f SHA512 52fde3efe09db3f5458e41a89bb57cf713336dd4f962dbc084b0c26a0e2f2b9cc624aeaca0740f736cbced507851a59102c4a7e19caa828a7a148b6890c4fce0 WHIRLPOOL 18abffd9fbbd128aeef6132d894e086cf4086172c8882a5d185d981c1e930078f87bcf7204cacc6746f5e2626b8b20108e4d3d124bbf5f0ddb83d9fcfe8c7fad
|
||||
MISC ChangeLog 357 SHA256 0937cd7956dae2401faf10782d0fb10f940fb4abd7b5733a7e9cd0cb00ccb1c7 SHA512 6a0cf14e18fd076686ef13285729f84f6c94caf4197eb52d62b5ab0fcc4e4e4fa6b19e312970b4812330022504c32598ab97a0b9bf03bf9eac83f0c3dc57c297 WHIRLPOOL 2c133d5180aef080ebd52e4b61907c5c5507c5cff16362eff2adb61bb06680770b1f81cf4d7c3d14e4e9bcad7ab4a285f5bf5bb817295a90c48ce3ee7aeb5d8c
|
||||
MISC metadata.xml 161 SHA256 6f41e9b782499f6bac80760066dc5ebb307e73d31d2080f2eaa383b8a236c68e SHA512 9d77a0cf6ef95d95fe0e41852a1ddedc8bc4a82d39fa75e8bbf760ba835deebe6ac3beddc83b9b70e381cee31936f54bb2db7cb88357ed2228c9e972cf2cac47 WHIRLPOOL 1f1ee9aa1b4b8747fb5f6c9234263952071a1a90100df893eb7fed974ea7c63639796521cfa1fde8929fc2f1bf0cc65e88ef6d703a2dff633816ff87cbf21411
|
@ -0,0 +1,21 @@
|
||||
# Copyright 1999-2013 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-python/bjoern/bjoern-1.3.2.ebuild,v 1.1 2013/09/04 08:34:55 patrick Exp $
|
||||
|
||||
EAPI=5
|
||||
|
||||
PYTHON_COMPAT=( python{2_6,2_7} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="A screamingly fast Python WSGI server written in C."
|
||||
HOMEPAGE="https://github.com/jonashaag/bjoern https://pypi.python.org/pypi/bjoern/"
|
||||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND="dev-libs/libev
|
||||
net-libs/http-parser"
|
||||
RDEPEND="${DEPEND}"
|
@ -0,0 +1,6 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<herd>python</herd>
|
||||
</pkgmetadata>
|
||||
|
@ -1,16 +1,5 @@
|
||||
-----BEGIN PGP SIGNED MESSAGE-----
|
||||
Hash: SHA256
|
||||
|
||||
AUX 0.56-libs.patch 813 SHA256 9c07725c983abcccb42df3d3f615d5cc95bc247613701e556cb079878f38a71c SHA512 97d9fa2bc6a09a08fbe11c9cf62d1b286a13d4d87710432cc8dc4fd2da18157666159d4fd11745c9ea7685587479daad07baa261058a254145995a1b73bde409 WHIRLPOOL 981b91f4dd9d2b6cb17547aa11f1c8a28565c0219a607a0463f09293f87bc9cf04a92dc0e5536b8e8fa997aefe2dfed115a8873cf76734b34b58ce474805b20d
|
||||
AUX gdmodule-0.56-fix-libs.patch 2629 SHA256 38221d3d1d1609eb696cbf59e8d1a8b9ea079607fed34eb1c5a5647e22a9c6ee SHA512 eb8993b77f5b893b568d87e572a19caf84ee11e4c0c76a13ef81e7185678bf007d7967e1d68ce56f869bc83cfe502b8f67ab0fee2f7f477e9aa2b4f0017e0a0a WHIRLPOOL ae1c5112cd4a549fc06f7b24f30236b51788ac7e7d10ae6e8eedaf22c04bf72cf45f80eb47c5e672f4257936972e902e659e8ea134f2c08f96c352ac59c92a51
|
||||
DIST gdmodule-0.56.tar.gz 48748 SHA256 a3a2fd6378e32f10a348c4db428a91e2c1adc28de6ec35c0619a52e379f4edec SHA512 9570a9c06a1c7d76af760fffe30cfde9a840620c608f0d55123898e030d6f3ab4c91fe75bf02b326f13f4a85ea5429c6a0ec0cd20fdc27fa83e656b81f7cce88 WHIRLPOOL e05702ca2fe129b9548f301a73b8a8b461f060dfef67e7b5135756ab70b6a996c55037c9ec60952a2577ed2468141af20ebe128f5312449b8e909092d6f8c5ad
|
||||
EBUILD gdmodule-0.56-r2.ebuild 1286 SHA256 ea8f123b456e0c2954c12ca7c897f362b539741269bd36650b6a70e2c4c68e24 SHA512 9f1e310d1eae276b1972578a2dd7f86160dc1027c8903a1c271ade4a9d49ec7739069ce559689befce76ec410090f35a21c5db923d4f8230786942400e67675e WHIRLPOOL bc9c08f243301827d239182e0fb4d189135a6a37d876d701ccafcb9a05fabd1d5a063a7ec1fb627b09da77bdffcb47d2260319238314d7c800293076060360fb
|
||||
MISC ChangeLog 1514 SHA256 636b19e6effd8c906e2883becfd2ab83882476b9570ec0def11c1757d768de5c SHA512 3d05714c51e4e1b8b6481d979337f6e64a2fb6cec75a79e9d87f6b3ae0d9708a5af4805392a97d110a2abc25e2485b23b6ad0e4187d47eef9a65c25e14a9a950 WHIRLPOOL 40d809e51ff7bedef98619f7a86ef9c75c89a8e657116f9bf55120c7e0f6675c0cee14444a581afc7a6beef0ff6af49047a6bc8aa0b2faffce8ed1829d20b10d
|
||||
MISC metadata.xml 265 SHA256 c1bb4042c02e9f553e826f5348138ca9b88ff2138866ba899db418ec2263c1fc SHA512 124728224b52316eda675472396fc06905e3018489ce2a3671542efa795bf7a3d9eb9375b8c99086d33a55929d583faf547fd4d3cbaece66d226f407fb993f7f WHIRLPOOL 396dd62dc214298eb023a46e4263670fb6a4f8a652872b3704add8d2b084bca3496d3ce816307f77e858c3fd9e470a9af306f50054ececc9954f9fb6bc3ab784
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v2.0.19 (GNU/Linux)
|
||||
|
||||
iEYEAREIAAYFAlAawTwACgkQ1ycZbhPLE2Dv0QCggC+q39S1o6FNZ10d0udNc2xZ
|
||||
sSUAn0to+mVr2DM1T1NzKzUr61M7RhdR
|
||||
=lGxz
|
||||
-----END PGP SIGNATURE-----
|
||||
EBUILD gdmodule-0.56-r2.ebuild 1219 SHA256 f8de3c0f74be7b0bfe2e81a6faa8810ab9f8ba29be65e8811e9a351f1e1e245f SHA512 bc5cd46823fc09525775a9984dd95a1bfd8e9f1e1a2b77ed1f59415646107338444615f1dd6143daa7026b51806be1ebf5a872a9935c137c189dad5e6260ddbb WHIRLPOOL 66204de1b0ab150e49b60ba6f46211e68a29abc31b539202a9c7921b3edb1dd7bc945191d2087bdf0baad3ee769f96478e530376460544d25776a45725123c49
|
||||
MISC ChangeLog 1687 SHA256 19ecab7647bb4b7d696bbea6cc50833136508415743fdaa8f5d0350d75dadc18 SHA512 cab1c87e3c30f393d4514c641dc18bd9775a3ed419f6ab9f3907bff2d3314d9597357e8c5fa563e4be3bee56a2422fb552d3056c2465b999ffdaca705b457d86 WHIRLPOOL 8a19ad8868b539362847211e096daaa508f49ec2d994c5749b73fe0ab8df9c3a6a85dd3e6e3b0dea5c777170e350eb7d4a3b0343ecf1efbc301daeab9743bebb
|
||||
MISC metadata.xml 257 SHA256 82a6d3a9f7fb60d32ecf96cf7924e4148ed5125f4237279dcda28775aee6b510 SHA512 4bd489f10360cfbeda28bc0b07e22a0add4a788b358c3db6437e5d7195306fb2b2623835ab5604fda713c9b63dee5fba18b686dc00450b4387ad33de547c9e76 WHIRLPOOL 69d950bee4c48cf65738ec4d70d93a6da662d02e5fbdf80adcf9c5653c339b54460663fe3946e8d07a93dd863cd875ca0a101184557316d4a8741059b7b57848
|
||||
|
@ -1,32 +0,0 @@
|
||||
diff --git a/Setup.py b/Setup.py
|
||||
index c6ef27f..8baedc4 100644
|
||||
--- a/Setup.py
|
||||
+++ b/Setup.py
|
||||
@@ -40,7 +40,7 @@ def remove(itm, lst):
|
||||
# Unixoid OS's I will just look for the usual suspects.
|
||||
|
||||
libdirs = dirtest([
|
||||
- "/usr/local/lib", "/sw/lib", "/usr/lib",
|
||||
+ "/usr/lib", "/usr/lib64",
|
||||
"/usr/lib/X11", "/usr/X11R6/lib",
|
||||
"/opt/gnome/lib",
|
||||
])
|
||||
@@ -48,7 +48,7 @@ libdirs = dirtest([
|
||||
# include_dirs are also non-portable; same trick here.
|
||||
|
||||
incdirs = dirtest([
|
||||
- "/usr/local/include", "/sw/include", "/usr/include",
|
||||
+ "/usr/include",
|
||||
"/usr/include/X11", "/usr/X11R6/include",
|
||||
"/opt/gnome/include",
|
||||
])
|
||||
@@ -57,9 +57,6 @@ incdirs = dirtest([
|
||||
|
||||
want_libs = [
|
||||
"gd",
|
||||
- "jpeg", "png", "gif", "z",
|
||||
- "X11", "Xpm",
|
||||
- "ttf", "freetype",
|
||||
]
|
||||
|
||||
libs = filetest(libdirs, want_libs)
|
@ -1,8 +1,8 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<herd>sci</herd>
|
||||
<longdescription lang="en">
|
||||
This module is a python wrapper for the GD library.
|
||||
</longdescription>
|
||||
<herd>sci</herd>
|
||||
<longdescription lang="en">
|
||||
This module is a python wrapper for the GD library.
|
||||
</longdescription>
|
||||
</pkgmetadata>
|
||||
|
Some files were not shown because too many files have changed in this diff Show More
Loading…
Reference in new issue