You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

41 lines
985 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
inherit gnome.org meson-multilib python-any-r1
DESCRIPTION="C++ interface for pango"
HOMEPAGE="https://www.gtkmm.org https://gitlab.gnome.org/GNOME/pangomm"
LICENSE="LGPL-2.1+"
SLOT="1.4"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
IUSE="gtk-doc"
RDEPEND="
>=dev-cpp/cairomm-1.2.2:0[gtk-doc?,${MULTILIB_USEDEP}]
>=dev-cpp/glibmm-2.48.0:2[gtk-doc?,${MULTILIB_USEDEP}]
dev-libs/libsigc++:2[gtk-doc?,${MULTILIB_USEDEP}]
>=x11-libs/pango-1.45.1[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
gtk-doc? (
>=dev-cpp/mm-common-1.0.4
app-text/doxygen[dot]
dev-libs/libxslt
)
${PYTHON_DEPS}
"
multilib_src_configure() {
local emesonargs=(
-Dmaintainer-mode=false
$(meson_native_use_bool gtk-doc build-documentation)
)
meson_src_configure
}