You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

29 lines
574 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit gap-pkg
DESCRIPTION="Compute Gröbner bases of noncommutative polynomials"
SLOT="0"
SRC_URI="https://github.com/gap-packages/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
KEYWORDS="~amd64"
IUSE="examples"
gap-pkg_enable_tests
src_prepare() {
# The GNUmakefile is used to produce the tarball, not to build the
# package.
rm GNUmakefile || die
default
}
src_install() {
gap-pkg_src_install
use examples && dodoc -r examples
}