You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

35 lines
945 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
DESCRIPTION="A python parser that supports error recovery and round-trip parsing"
HOMEPAGE="
https://github.com/davidhalter/parso/
https://pypi.org/project/parso/
"
SRC_URI="
https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
distutils_enable_sphinx docs
distutils_enable_tests pytest
EPYTEST_DESELECT=(
# py3.10 changed exception messages
test/test_python_errors.py::test_python_exception_matches
# With python3.11 this additional file is run by pytest,
# but it is not actually a test and thus fails
parso/python/token.py::parso.python.token.PythonTokenTypes
)