You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

37 lines
723 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt5-build
DESCRIPTION="Qt module to support gamepad hardware"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 ~arm arm64 ~riscv x86"
fi
IUSE="evdev qml sdl"
DEPEND="
=dev-qt/qtcore-${QT5_PV}*
=dev-qt/qtgui-${QT5_PV}*[evdev?]
evdev? ( virtual/libudev:= )
qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
sdl? ( media-libs/libsdl2 )
"
RDEPEND="${DEPEND}"
src_prepare() {
qt_use_disable_mod qml quick \
src/src.pro
qt_use_disable_config evdev evdev \
src/plugins/gamepads/gamepads.pro
qt_use_disable_config sdl sdl2 \
src/plugins/gamepads/gamepads.pro
qt5-build_src_prepare
}