You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

40 lines
808 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt5-build
DESCRIPTION="XPath, XQuery, XSLT, and XML Schema validation library for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
fi
IUSE="qml"
DEPEND="
=dev-qt/qtcore-${QT5_PV}*
=dev-qt/qtnetwork-${QT5_PV}*
qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
RDEPEND="${DEPEND}
!<dev-qt/qtchooser-66-r2
"
src_prepare() {
qt_use_disable_mod qml qml \
src/src.pro \
src/imports/imports.pro
qt_use_disable_mod qml quick tests/auto/auto.pro
qt5-build_src_prepare
}
src_install() {
qt5-build_src_install
qt5_symlink_binary_to_path xmlpatterns
qt5_symlink_binary_to_path xmlpatternsvalidator
}