You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

32 lines
601 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Send a collection of patches as emails"
HOMEPAGE="https://github.com/roman-neuhauser/git-mailz/"
SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
app-shells/zsh
dev-vcs/git
virtual/mta
"
BDEPEND="test? ( dev-util/cram )"
src_compile() {
emake GZIPCMD="true"
}
src_install() {
emake PREFIX="${ED}/usr" install
mv "${ED}"/usr/share/man/man1/git-mailz.1{.gz,} || die
}