You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

41 lines
996 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9,10,11} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
inherit distutils-r1
DESCRIPTION="Python command line interface to gitlab API"
HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
inherit git-r3
else
inherit pypi
KEYWORDS="~amd64"
fi
LICENSE="LGPL-3"
SLOT="0"
BDEPEND="test? (
dev-python/coverage[${PYTHON_USEDEP}]
>=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
dev-python/pytest-cov[${PYTHON_USEDEP}]
>=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
)"
RDEPEND=">=dev-python/requests-2.28.2[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.10.1[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
python_install_all() {
distutils-r1_python_install_all
dodoc -r *.rst docs
}