You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

39 lines
730 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Manage config files in \$HOME via fake bare git repositories"
HOMEPAGE="https://github.com/RichiH/vcsh"
SRC_URI="https://github.com/RichiH/vcsh/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-vcs/git"
BDEPEND="
test? (
dev-lang/perl
dev-perl/Shell-Command
dev-perl/Test-Most
)
"
src_configure() {
econf \
$(use_enable test tests) \
--with-man-page \
--with-deployment=${PR}
}
src_install() {
default
mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
dodoc -r doc/sample_hooks
}