You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

33 lines
678 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="LXQt about dialog"
HOMEPAGE="https://lxqt-project.org/"
MY_PV="$(ver_cut 1-2)"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
fi
LICENSE="LGPL-2.1+"
SLOT="0"
BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
DEPEND="
>=dev-libs/libqtxdg-3.11.0
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
=lxqt-base/liblxqt-${MY_PV}*:=
"
RDEPEND="${DEPEND}"