You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

36 lines
802 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="LXQt system administration tool"
HOMEPAGE="https://lxqt-project.org/"
MY_PV="$(ver_cut 1-2)"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
KEYWORDS="amd64 ~arm arm64 ~loong ~riscv x86"
fi
LICENSE="LGPL-2.1+"
SLOT="0"
BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
DEPEND="
>=dev-qt/qtcore-5.15:5
>=dev-qt/qtdbus-5.15:5
>=dev-qt/qtgui-5.15:5
>=dev-qt/qtwidgets-5.15:5
=lxqt-base/liblxqt-${MY_PV}*
kde-frameworks/kwindowsystem:5
>=sys-auth/polkit-qt-0.113.0[qt5(+)]
=lxqt-base/liblxqt-${MY_PV}*:=
"
RDEPEND="${DEPEND}"