You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

38 lines
718 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="A parallel port pin programming library"
HOMEPAGE="https://parapin.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="LGPL-2.1"
IUSE="doc"
KEYWORDS="~amd64 ~x86"
SLOT="0"
PATCHES=(
"${FILESDIR}"/${P}-tc-directly.patch
)
src_compile() {
tc-export AR CC
# Note 2.4 and 2.6 makefiles are identical for the targets used
emake -f Makefile-2.4
}
src_install() {
einstalldocs
dolib.a libparapin.a
insopts -m0444; insinto /usr/include; doins parapin.h
if use doc; then
cd examples || die
docinto examples
dodoc *.c
fi
}