You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

31 lines
758 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit dune
DESCRIPTION="Binary protocol generator"
HOMEPAGE="https://github.com/janestreet/bin_prot"
SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
IUSE="+ocamlopt"
RDEPEND="
>=dev-lang/ocaml-4.14
dev-ml/base:${SLOT}
dev-ml/findlib:=
dev-ml/ppx_compare:${SLOT}
dev-ml/ppx_custom_printf:${SLOT}
dev-ml/ppx_fields_conv:${SLOT}
dev-ml/ppx_optcomp:${SLOT}
dev-ml/ppx_sexp_conv:${SLOT}
dev-ml/ppx_stable_witness:${SLOT}
dev-ml/ppx_variants_conv:${SLOT}
dev-ml/variantslib:=
"
DEPEND="${RDEPEND}"