You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

33 lines
678 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit findlib
DESCRIPTION="Pretty-printing library for OCaml"
HOMEPAGE="https://github.com/ocaml-community/easy-format"
SRC_URI="https://github.com/ocaml-community/easy-format/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0/${PV}"
LICENSE="BSD"
KEYWORDS="amd64"
IUSE="examples +ocamlopt"
RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
DEPEND="${RDEPEND}"
src_compile() {
emake all
use ocamlopt && emake opt
}
src_install() {
findlib_src_install
dodoc README.md Changes
if use examples ; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}