You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

29 lines
497 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=flit
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="A low-level PDF generator"
HOMEPAGE="
https://pypi.org/project/pydyf/
https://github.com/CourtBouillon/pydyf/
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
BDEPEND="
test? (
app-text/ghostscript-gpl
dev-python/pillow[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest