You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

35 lines
776 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1
DESCRIPTION="Sniff out which async library your code is running under"
HOMEPAGE="
https://github.com/python-trio/sniffio/
https://pypi.org/project/sniffio/
"
SRC_URI="
https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
EPYTEST_DESELECT=(
# curio is not packaged
sniffio/_tests/test_sniffio.py::test_curio
)