You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

26 lines
530 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
inherit ruby-fakegem
DESCRIPTION="Console coloring"
HOMEPAGE="https://github.com/kigster/colored2"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE=""
each_ruby_prepare() {
sed -i -e '/bundler/ s:^:#:' Rakefile || die
sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
sed -i -e 's/Fixnum/Integer/' lib/colored2/numbers.rb || die
}