You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

30 lines
785 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="Module that adds descendant tracking to a class"
HOMEPAGE="https://github.com/dkubb/descendants_tracker"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
ruby_add_rdepend "dev-ruby/thread_safe"
all_ruby_prepare() {
# Remove dependency on devtools
sed -i -e '/devtools\/spec_helper/d' spec/spec_helper.rb || die
sed -i -e '/it_should_behave_like/d' \
spec/unit/descendants_tracker/add_descendant_spec.rb || die
sed -i -e '/it_should_behave_like/d' \
spec/unit/descendants_tracker/descendants_spec.rb || die
}