You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

35 lines
742 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
RUBY_FAKEGEM_TASK_TEST=""
inherit ruby-fakegem
DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
HOMEPAGE="http://rgplot.rubyforge.org/"
LICENSE="BSD"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
SLOT="0"
RDEPEND+=" sci-visualization/gnuplot"
all_ruby_prepare() {
# Existing metadata causes a crash in jruby, so use our own.
rm -f ../metadata || die "Unable to remove metadata."
sed -i -e 's/Config/RbConfig/' test/test_gnuplot.rb || die
}
each_ruby_test() {
${RUBY} -Ctest test_gnuplot.rb || die
}