You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

40 lines
927 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
RUBY_FAKEGEM_EXTENSIONS=(ext/google/protobuf_c/extconf.rb)
RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/google
inherit ruby-fakegem
DESCRIPTION="Protocol Buffers are Google's data interchange format"
HOMEPAGE="https://protobuf.dev/"
SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
RUBY_S="protobuf-${PV}/ruby"
LICENSE="BSD"
SLOT="3"
KEYWORDS="~amd64 ~arm64"
IUSE=""
DEPEND+=" >=dev-libs/protobuf-3.21.0"
all_ruby_prepare() {
sed -e '/extensiontask/ s:^:#:' \
-e '/ExtensionTask/,/^ end/ s:^:#:' \
-e 's:../src/protoc:protoc:' \
-e 's/:compile,//' \
-e '/:test/ s/:build,//' \
-i Rakefile || die
}
each_ruby_prepare() {
${RUBY} -S rake genproto || die
}