You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

31 lines
812 B

# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_BINWRAP=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="leto.gemspec"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
inherit ruby-fakegem
DESCRIPTION="Generic object traverser for Ruby"
HOMEPAGE="https://github.com/jaynetics/leto"
SRC_URI="https://github.com/jaynetics/leto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="$(ver_cut 1)"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE=""
all_ruby_prepare() {
sed -e 's:_relative ": "./:' \
-e 's/git ls-files -z/find * -print0/' \
-e 's/__dir__/"."/' \
-i ${RUBY_FAKEGEM_GEMSPEC} || die
sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
}