You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

25 lines
565 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
inherit ruby-fakegem
DESCRIPTION="Mash is an extended Hash that gives simple pseudo-object functionality"
HOMEPAGE="https://github.com/mbleigh/mash"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
all_ruby_prepare() {
sed -i -e 's/be_true/be true/' -e 's/be_false/be false/' spec/mash_spec.rb || die
}