You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

29 lines
641 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
inherit ruby-fakegem
DESCRIPTION="Memoize method return values"
HOMEPAGE="https://github.com/dkubb/memoizable"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
ruby_add_rdepend ">=dev-ruby/thread_safe-0.3.1:0"
all_ruby_prepare() {
sed -i -e "/simplecov/,/^end$/d" spec/spec_helper.rb || die
# Avoid a failing test that also fails for upstream Travis.
rm spec/unit/memoizable/class_methods/included_spec.rb || die
}