You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

36 lines
933 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby26 ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_TEST="MOCHA_NO_DOCS=true test:units"
RUBY_FAKEGEM_EXTRADOC="README.md RELEASE.md"
RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
inherit ruby-fakegem
DESCRIPTION="Mocking and stubbing using a syntax like that of JMock and SchMock"
HOMEPAGE="http://gofreerange.com/mocha/docs/"
LICENSE="MIT"
SLOT="0.14"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
IUSE=""
ruby_add_bdepend "
test? ( >=dev-ruby/test-unit-2.5.1-r1 dev-ruby/introspection )"
ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
PATCHES=(
"${FILESDIR}"/${PN}-1.16.0-ruby32.patch
)
all_ruby_prepare() {
sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
sed -i -e '20irequire "mocha/setup"' test/test_helper.rb || die
}