You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

26 lines
531 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="README"
inherit ruby-fakegem
DESCRIPTION="A pure Ruby library for generating podcasts from mp3 files"
HOMEPAGE="https://github.com/boncey/ruby-podcast"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
ruby_add_rdepend "dev-ruby/ruby-mp3info"
each_ruby_test() {
${RUBY} -Ilib test/ts_podcast.rb || die "Tests failed."
}