You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

37 lines
758 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="README"
inherit ruby-fakegem
DESCRIPTION="A ruby library for performing Yadis service discovery"
HOMEPAGE="https://rubygems.org/gems/ruby-yadis"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
each_ruby_prepare() {
# Remove live tests that require content that is no longer available.
rm test/test_discovery.rb || die
sed -i -e '/test_discovery/d' test/runtests.rb || die
}
each_ruby_test() {
${RUBY} -I../lib:lib:test -Ctest runtests.rb || die
}
all_ruby_install() {
all_fakegem_install
dodoc -r examples
}