You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

24 lines
553 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
inherit ruby-fakegem
DESCRIPTION="A simple opinionated mocking framework"
HOMEPAGE="https://github.com/ryanong/spy"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/minitest )"
all_ruby_prepare() {
sed -i -e "/bundler/d" -e "/pry/d" -e "/[Cc]overalls/d" -e '/[Rr]eporters/d' Rakefile test/test_helper.rb || die
}