You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

36 lines
679 B

# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="A web-based viewer for Python profiler output"
HOMEPAGE="
https://github.com/jiffyclub/snakeviz/
https://pypi.org/project/snakeviz/
"
SRC_URI="
https://github.com/jiffyclub/snakeviz/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64"
RDEPEND="
dev-python/tornado[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest