You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

197 lines
4.3 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CARGO_OPTIONAL=1
DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_EXT=1
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 cargo elisp-common distutils-r1 mercurial flag-o-matic multiprocessing
DESCRIPTION="Scalable distributed SCM"
HOMEPAGE="https://www.mercurial-scm.org/"
EHG_REPO_URI="https://www.mercurial-scm.org/repo/hg"
LICENSE="GPL-2+"
SLOT="0"
IUSE="+chg emacs gpg test tk rust"
BDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
rust? ( ${RUST_DEPEND} )"
RDEPEND="
app-misc/ca-certificates
gpg? ( app-crypt/gnupg )
tk? ( dev-lang/tk )"
DEPEND="emacs? ( >=app-editors/emacs-23.1:* )
test? (
app-arch/unzip
dev-python/pygments[${PYTHON_USEDEP}]
)"
SITEFILE="70${PN}-gentoo.el"
RESTRICT="!test? ( test )"
src_unpack() {
mercurial_src_unpack
if use rust; then
local S="${S}/rust/hg-cpython"
cargo_live_src_unpack
fi
}
python_prepare_all() {
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
sed -i -e 's/__APPLE__/__NO_APPLE__/g' mercurial/cext/osutil.c || die
distutils-r1_python_prepare_all
}
src_compile() {
if use rust; then
pushd rust/hg-cpython || die
cargo_src_compile --no-default-features --jobs $(makeopts_jobs)
popd || die
fi
distutils-r1_src_compile
}
python_compile() {
filter-flags -ftracer -ftree-vectorize
if use rust; then
local -x HGWITHRUSTEXT="cpython"
fi
distutils-r1_python_compile build_ext
}
python_compile_all() {
rm -r contrib/win32 || die
emake doc
if use chg; then
emake -C contrib/chg
fi
if use rust; then
pushd rust/rhg || die
cargo_src_compile --no-default-features --jobs $(makeopts_jobs)
popd || die
fi
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
}
src_install() {
distutils-r1_src_install
}
python_install() {
if use rust; then
local -x HGWITHRUSTEXT="cpython"
fi
distutils-r1_python_install build_ext
python_doscript contrib/hg-ssh
}
python_install_all() {
distutils-r1_python_install_all
newbashcomp contrib/bash_completion hg
insinto /usr/share/zsh/site-functions
newins contrib/zsh_completion _hg
dobin hgeditor
if use tk; then
dobin contrib/hgk
fi
if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
elisp-make-site-file "${SITEFILE}"
fi
local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion plan9 *.el )
if use chg; then
dobin contrib/chg/chg
doman contrib/chg/chg.1
RM_CONTRIB+=( chg )
fi
if use rust; then
dobin rust/target/release/rhg
fi
for f in ${RM_CONTRIB[@]}; do
rm -rf contrib/${f} || die
done
dodoc -r contrib
docompress -x /usr/share/doc/${PF}/contrib
doman doc/*.?
dodoc CONTRIBUTORS hgweb.cgi
insinto /etc/mercurial/hgrc.d
doins "${FILESDIR}/cacerts.rc"
}
src_test() {
pushd tests &>/dev/null || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive* # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz
rm -f test-convert-cvs* # CVS
rm -f test-convert-darcs* # Darcs
rm -f test-convert-git* # git
rm -f test-convert-mtn* # monotone
rm -f test-convert-tla* # GNU Arch tla
rm -f test-largefiles* # tends to time out
rm -f test-https* # requires to support tls1.0
rm -rf test-removeemptydirs* # requires access to access parent directories
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-convert*
rm -f test-lock-badness*
rm -f test-permissions*
rm -f test-pull-permission*
rm -f test-journal-exists*
rm -f test-repair-strip*
fi
popd &>/dev/null || die
distutils-r1_src_test
}
python_test() {
cd tests || die
PYTHONWARNINGS=ignore "${PYTHON}" run-tests.py \
--jobs $(makeopts_jobs) \
--timeout 0 \
|| die "Tests fail with ${EPYTHON}"
}
pkg_postinst() {
use emacs && elisp-site-regen
elog "If you want to convert repositories from other tools using convert"
elog "extension please install correct tool:"
elog " dev-vcs/cvs"
elog " dev-vcs/darcs"
elog " dev-vcs/git"
elog " dev-vcs/monotone"
elog " dev-vcs/subversion"
}
pkg_postrm() {
use emacs && elisp-site-regen
}