You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

44 lines
847 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Fly about 3D-formed file system"
HOMEPAGE="https://xcruiser.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
RESTRICT="test"
RDEPEND="x11-libs/libXaw"
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
sys-devel/gcc
x11-misc/gccmakedep
>=x11-misc/imake-1.0.8-r1"
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf -a || die
}
src_compile() {
local myemakeargs=(
CC="$(tc-getCC)"
CDEBUGFLAGS="${CFLAGS}"
LOCAL_LDFLAGS="${LDFLAGS}"
)
emake "${myemakeargs[@]}"
}
src_install() {
dobin xcruiser
newman xcruiser.man xcruiser.1
einstalldocs
}