You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

34 lines
764 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.9
inherit ecm frameworks.kde.org
DESCRIPTION="Address book API based on KDE Frameworks"
LICENSE="GPL-2+"
KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
IUSE=""
RDEPEND="
>=dev-qt/qtgui-${QTMIN}:5
=kde-frameworks/kcodecs-${PVCUT}*:5
=kde-frameworks/kconfig-${PVCUT}*:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
=kde-frameworks/ki18n-${PVCUT}*:5
"
DEPEND="${RDEPEND}
test? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
"
CMAKE_SKIP_TESTS=(
# bug #566648 (access to /dev/dri/card0 denied)
kcontacts-picturetest
# bug #838502 (again some Qt translations loading related err...)
kcontacts-addresstest
)