You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

34 lines
739 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=6.6.2
inherit ecm frameworks.kde.org
DESCRIPTION="Address book API based on KDE Frameworks"
LICENSE="GPL-2+"
KEYWORDS="~amd64"
IUSE=""
RDEPEND="
>=dev-qt/qtbase-${QTMIN}:6[gui]
=kde-frameworks/kcodecs-${PVCUT}*:6
=kde-frameworks/kconfig-${PVCUT}*:6
=kde-frameworks/kcoreaddons-${PVCUT}*:6
=kde-frameworks/ki18n-${PVCUT}*:6
"
DEPEND="${RDEPEND}
test? ( >=dev-qt/qtdeclarative-${QTMIN}:6 )
"
CMAKE_SKIP_TESTS=(
# bug #566648 (access to /dev/dri/card0 denied)
kcontacts-picturetest
# bug #838502 (again some Qt translations loading related err...)
kcontacts-addresstest
)