You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

40 lines
777 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.9
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for intercepting and handling application crashes"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~loong ppc64 ~riscv x86"
IUSE="X"
# requires running Plasma environment
RESTRICT="test"
RDEPEND="
>=dev-qt/qtgui-${QTMIN}:5
=kde-frameworks/kcoreaddons-${PVCUT}*:5
X? (
>=dev-qt/qtx11extras-${QTMIN}:5
x11-libs/libX11
)
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"
BDEPEND=">=dev-qt/linguist-tools-${QTMIN}:5"
src_configure() {
local mycmakeargs=(
-DWITH_X11=$(usex X)
)
ecm_src_configure
}