You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

37 lines
720 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-2)
QTMIN=6.6.2
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for intercepting and handling application crashes"
LICENSE="LGPL-2+"
KEYWORDS="~amd64"
IUSE="X"
# requires running Plasma environment
RESTRICT="test"
RDEPEND="
>=dev-qt/qtbase-${QTMIN}:6[gui]
=kde-frameworks/kcoreaddons-${PVCUT}*:6
X? ( x11-libs/libX11 )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
"
BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
src_configure() {
local mycmakeargs=(
-DWITH_X11=$(usex X)
)
ecm_src_configure
}