You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

33 lines
665 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
QTMIN=6.6.2
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for network service discovery using Zeroconf"
LICENSE="LGPL-2+"
KEYWORDS="~amd64"
IUSE="zeroconf"
DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[network]
zeroconf? (
>=dev-qt/qtbase-${QTMIN}:6[dbus]
net-dns/avahi[mdnsresponder-compat]
)
"
RDEPEND="${DEPEND}"
BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package zeroconf Avahi)
)
use zeroconf || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_DNSSD=ON )
ecm_src_configure
}