You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

41 lines
875 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="C library for encoding data in a QR Code symbol"
HOMEPAGE="https://fukuchi.org/works/qrencode/"
SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0/4"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
IUSE="png test"
RESTRICT="!test? ( test )"
RDEPEND="
png? ( media-libs/libpng:0= )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
local myconf=(
$(use_with png)
$(use_with test tests)
# TODO: figure out how to make SDL check fail as the SDL test
# program is not useful
)
econf "${myconf[@]}"
}
src_test() {
cd tests || die
./test_basic.sh || die
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}