You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

32 lines
717 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Take an SVG file and produce a cleaner and more concise file"
HOMEPAGE="
https://github.com/scour-project/scour/
https://pypi.org/project/scour/
"
SRC_URI="
https://github.com/scour-project/${PN}/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
python_test() {
"${EPYTHON}" test_scour.py -v || die "Tests fail with ${EPYTHON}"
}