You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

36 lines
641 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Analysis of repetitive DNA found in genome sequences"
HOMEPAGE="http://www.drive5.com/piler/"
SRC_URI="http://www.drive5.com/piler/piler_source.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ~x86"
RDEPEND="
|| (
sci-biology/muscle
sci-libs/libmuscle
)
sci-biology/pals"
PATCHES=(
"${FILESDIR}"/${PN}-1.0-fix-build-system.patch
"${FILESDIR}"/${PN}-1.0-glibc-2.10.patch
)
src_configure() {
tc-export CXX
}
src_install() {
dobin piler
}