You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

32 lines
701 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="GKrellM2 Plugin for the Dell Inspiron and Latitude notebooks"
SRC_URI="http://www.coding-zone.com/${P}.tar.gz"
HOMEPAGE="http://www.coding-zone.com/?page=i8krellm"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
app-admin/gkrellm:2[X]
>=app-laptop/i8kutils-1.5"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-Respect-LDFLAGS.patch
"${FILESDIR}"/${P}-r3-makefile-fixes.patch
"${FILESDIR}"/${P}-r3-rm-gkrellm1-support.patch
)
src_compile() {
tc-export PKG_CONFIG
emake CC="$(tc-getCC)"
}