You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

35 lines
732 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="a nifty little binary clock dockapp"
HOMEPAGE="https://www.dockapps.net/wmbinclock"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86"
RDEPEND="x11-libs/libX11
x11-libs/libXpm
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
INCDIR="-I/usr/include/X11" LIBDIR="" \
SYSTEM="${LDFLAGS}"
}
src_install() {
dobin wmBinClock
dosym wmBinClock /usr/bin/${PN}
dodoc CHANGELOG README
}