42 lines
1 KiB
Diff
42 lines
1 KiB
Diff
--- /dev/null
|
|
+++ b/libev.pc.in
|
|
@@ -0,0 +1,11 @@
|
|
+prefix=@prefix@
|
|
+exec_prefix=@prefix@
|
|
+libdir=@libdir@
|
|
+includedir=@includedir@
|
|
+
|
|
+Name: libev
|
|
+Description: A high-performance event loop/event model with lots of features
|
|
+Version: @VERSION@
|
|
+Libs: -L${libdir} -lev
|
|
+Libs.private:
|
|
+Cflags: -I${includedir}
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -16,5 +16,8 @@ lib_LTLIBRARIES = libev.la
|
|
libev_la_SOURCES = ev.c event.c
|
|
libev_la_LDFLAGS = -version-info $(VERSION_INFO)
|
|
|
|
+pkgconfigdir = $(libdir)/pkgconfig
|
|
+pkgconfig_DATA = libev.pc
|
|
+
|
|
ev.3: ev.pod
|
|
pod2man -n LIBEV -r "libev-$(VERSION)" -c "libev - high performance full featured event loop" -s3 <$< >$@
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2,6 +2,7 @@ orig_CFLAGS="$CFLAGS"
|
|
|
|
AC_INIT
|
|
AC_CONFIG_SRCDIR([ev_epoll.c])
|
|
+AC_CONFIG_MACRO_DIR([m4])
|
|
|
|
AM_INIT_AUTOMAKE(libev,4.11) dnl also update ev.h!
|
|
AC_CONFIG_HEADERS([config.h])
|
|
@@ -21,5 +22,5 @@ AC_PROG_LIBTOOL
|
|
|
|
m4_include([libev.m4])
|
|
|
|
-AC_CONFIG_FILES([Makefile])
|
|
+AC_CONFIG_FILES([Makefile libev.pc])
|
|
AC_OUTPUT
|