78 lines
3.6 KiB
Diff
78 lines
3.6 KiB
Diff
diff -ur mozart-1.3.2.20060615-std.orig/Makefile.in mozart-1.3.2.20060615-std/Makefile.in
|
|
--- mozart-1.3.2.20060615-std.orig/Makefile.in 2004-05-19 02:22:05.000000000 +1200
|
|
+++ mozart-1.3.2.20060615-std/Makefile.in 2007-02-17 11:12:09.000000000 +1300
|
|
@@ -12,6 +12,7 @@
|
|
NOTDIRSRCDIR = $(notdir $(SRCDIR))
|
|
BUILDDATE = $(shell date '+%Y%m%d')
|
|
VERSION = $(shell $(OZTOOL) version)
|
|
+BINDIR = $(PREFIX)/bin
|
|
|
|
ifeq ($(PLATFORM),win32-i486)
|
|
OZEMULATOR = $(shell $(CYGPATH) $(PREFIX)/platform/win32-i486/emulator.dll)
|
|
@@ -22,11 +23,14 @@
|
|
$(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR)
|
|
|
|
build.ozmake:
|
|
- cd ozmake && $(MAKE) ozmake.ozf
|
|
+ cd ozmake && $(MAKE) ozmake
|
|
|
|
install: all
|
|
$(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR) --install --nosavedb
|
|
$(OZENGINE) ozmake/ozmake.ozf --prefix=$(CYG_PREFIX) --srcdir=$(CYG_SRCDIR)/ozmake --builddir=$(CYG_BUILDDIR_OZMAKE) --install --nosavedb
|
|
+ mkdir -p $(BINDIR)
|
|
+ cp ozmake/ozmake $(BINDIR)
|
|
+ chmod +x $(BINDIR)/ozmake
|
|
|
|
export CLEANDIR
|
|
|
|
diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Attribs.oz mozart-1.3.2.20060615-std/ozmake/Attribs.oz
|
|
--- mozart-1.3.2.20060615-std.orig/ozmake/Attribs.oz 2004-05-15 03:21:43.000000000 +1200
|
|
+++ mozart-1.3.2.20060615-std/ozmake/Attribs.oz 2007-02-17 09:29:47.000000000 +1300
|
|
@@ -458,7 +458,7 @@
|
|
end
|
|
|
|
meth get_oz_home($) {Path.expand {Property.get 'oz.home'}} end
|
|
- meth get_oz_bindir($) {Path.resolve Attribs,get_oz_home($) 'bin'} end
|
|
+ meth get_oz_bindir($) {Path.resolve '/usr/lib/mozart' 'bin'} end
|
|
meth get_oz_engine($)
|
|
if @OzEngine==unit then
|
|
P={Path.resolveAtom Attribs,get_oz_bindir($) 'ozengine.exe'}
|
|
diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Makefile.in mozart-1.3.2.20060615-std/ozmake/Makefile.in
|
|
--- mozart-1.3.2.20060615-std.orig/ozmake/Makefile.in 2004-04-01 00:52:55.000000000 +1200
|
|
+++ mozart-1.3.2.20060615-std/ozmake/Makefile.in 2007-02-17 10:55:26.000000000 +1300
|
|
@@ -37,8 +37,8 @@
|
|
|
|
# these additional 2 lines makes it possible to build in a directory
|
|
# different from the source directory
|
|
-OZLOAD = prefix=$(CYGSRCDIR)=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGSRCDIR)$(OZLOADSEP)cache=~/.oz/cache$(OZLOADSEP)cache=$(OZHOME)/cache
|
|
-export OZLOAD
|
|
+# OZLOAD = prefix=$(CYGSRCDIR)=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGBUILDDIR)$(OZLOADSEP)root=$(CYGSRCDIR)$(OZLOADSEP)cache=~/.oz/cache$(OZLOADSEP)cache=$(OZHOME)/cache
|
|
+# export OZLOAD
|
|
|
|
XSLTPROC = @VAR_XSLTPROC@
|
|
LYNX = @VAR_LYNX@
|
|
diff -ur mozart-1.3.2.20060615-std.orig/ozmake/Makefile.vars mozart-1.3.2.20060615-std/ozmake/Makefile.vars
|
|
--- mozart-1.3.2.20060615-std.orig/ozmake/Makefile.vars 2005-06-05 01:47:45.000000000 +1200
|
|
+++ mozart-1.3.2.20060615-std/ozmake/Makefile.vars 2007-02-17 08:42:20.000000000 +1300
|
|
@@ -13,6 +13,6 @@
|
|
MakeGUI.oz Fixes.oz DatabaseLib.oz CHANGES Config.oz Mogul.oz \
|
|
Pickler.oz ExecutorFast.oz Depends.oz Requires.oz
|
|
PKG_INSTALLS = ozmake.ozf
|
|
-PKG_INSTALLS_BIN= ozmake ozmake.win
|
|
+PKG_INSTALLS_BIN= ozmake
|
|
PKG_UPDATE = tgz tarz
|
|
PKG_INSTALLS_DOC= index.html CHANGES
|
|
diff -ur mozart-1.3.2.20060615-std.orig/ozmake/makefile.oz mozart-1.3.2.20060615-std/ozmake/makefile.oz
|
|
--- mozart-1.3.2.20060615-std.orig/ozmake/makefile.oz 2004-05-22 09:37:24.000000000 +1200
|
|
+++ mozart-1.3.2.20060615-std/ozmake/makefile.oz 2007-02-17 12:15:46.000000000 +1300
|
|
@@ -4,8 +4,8 @@
|
|
mogul : 'mogul:/mozart/ozmake'
|
|
author: 'mogul:/duchier/denys'
|
|
lib : ['ozmake.ozf']
|
|
- bin : ['ozmake.exe']
|
|
- doc : ['index.html' 'CHANGES']
|
|
+% bin : ['ozmake.exe']
|
|
+% doc : ['index.html' 'CHANGES']
|
|
rules :
|
|
o(
|
|
'ozmake.ozf' : ozl('Main.ozf')
|