You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

45 lines
1.3 KiB

--- libnatpmp-20110715/Makefile
+++ libnatpmp-20110715/Makefile
@@ -33,7 +32,7 @@
HEADERS = natpmp.h
-EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
+EXECUTABLES = testgetgateway natpmpc-shared
INSTALLPREFIX ?= $(PREFIX)/usr
INSTALLDIRINC = $(INSTALLPREFIX)/include
@@ -45,9 +44,9 @@
.PHONY: all clean depend install cleaninstall installpythonmodule
-all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
+all: $(SHAREDLIB) $(EXECUTABLES)
-pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
+pythonmodule: libnatpmpmodule.c setup.py
python setup.py build
touch $@
@@ -55,11 +54,10 @@
depend:
makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
-install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
+install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
$(INSTALL) -d $(INSTALLDIRINC)
$(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
$(INSTALL) -d $(INSTALLDIRLIB)
- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
$(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
$(INSTALL) -d $(INSTALLDIRBIN)
$(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
@@ -76,7 +74,6 @@
$(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
$(RM) $(INSTALLDIRLIB)/$(SONAME)
$(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
testgetgateway: testgetgateway.o getgateway.o