You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-full-overlay/app-arch/atool/files/atool-0.39.0-configure-bash...

13 lines
365 B

https://bugs.gentoo.org/775158
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,7 @@ AC_DEFINE_DIR(LOCALSTATEDIR, localstatedir)
dnl Perl stuff
AC_PATH_PROG([PERL], [perl])
eval `$PERL -V:startperl`
-if test "${startperl:0:1}" = "#" ; then
+if test "$(printf %.1s "$startperl")" = "#" ; then
startperl="\\$startperl"
fi
AC_SUBST(PERL_SHEBANG, $startperl)