You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
28 lines
920 B
28 lines
920 B
diff -Naur speex-1.2.0.orig/configure.ac speex-1.2.0/configure.ac
|
|
--- speex-1.2.0.orig/configure.ac 2016-12-12 13:53:12.254983043 -0800
|
|
+++ speex-1.2.0/configure.ac 2016-12-12 13:58:44.950298126 -0800
|
|
@@ -138,7 +138,7 @@
|
|
AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
|
|
if test "x$enableval" != xno; then
|
|
has_sse=yes
|
|
-CFLAGS="$CFLAGS -O3 -msse"
|
|
+CFLAGS="$CFLAGS -msse"
|
|
else
|
|
has_sse=no
|
|
fi
|
|
@@ -257,7 +257,13 @@
|
|
|
|
AM_CONDITIONAL(BUILD_VORBIS_PSY, [test "x$vorbis_psy" = "xyes"])
|
|
|
|
-PKG_CHECK_MODULES([SPEEXDSP], [speexdsp], [AC_DEFINE([USE_SPEEXDSP], [], [Use SpeexDSP library])], [speexdsp_failed=yes])
|
|
+AC_ARG_WITH(speexdsp, [ --without-speexdsp Do not build with SpeexDSP])
|
|
+if test "x$withval" != xno; then
|
|
+ PKG_CHECK_MODULES([SPEEXDSP], [speexdsp], [AC_DEFINE([USE_SPEEXDSP], [], [Use SpeexDSP library])])
|
|
+else
|
|
+ AC_DEFINE([USE_SPEEXDSP], false)
|
|
+fi
|
|
+
|
|
|
|
|
|
AC_CHECK_SIZEOF([int16_t])
|