gentoo-full-overlay/sci-astronomy/sextractor/files/sextractor-configure.patch

84 lines
2.2 KiB
Diff

--- configure.ac.orig 2009-04-09 14:28:38.000000000 +0100
+++ configure.ac 2009-07-28 18:25:38.000000000 +0100
@@ -22,42 +22,19 @@
# Include macros
sinclude(acx_atlas.m4)
sinclude(acx_fftw.m4)
-sinclude(acx_prog_cc_optim.m4)
sinclude(acx_pthread.m4)
sinclude(acx_urbi_resolve_dir.m4)
# Display pakage and version number
AC_MSG_RESULT([*********** Configuring: $PACKAGE $VERSION ($date) **********])
-# Initialize the list of compilers to consider
-cclist="cc gcc"
-
-# Backup and reset the input CFLAGS and LDFLAGS
-mycflags="$CFLAGS"
-CFLAGS=""
-myldflags="$LDFLAGS"
-LDFLAGS=""
-
-# Provide special option for the Linux Intel C compiler
-AC_MSG_CHECKING([for Linux Intel C compiler mode])
-AC_ARG_ENABLE(icc,
- [AC_HELP_STRING([--enable-icc],
- [Enable special mode for compilation with the Intel compiler \
-(off by default)])],
- use_icc="yes"
- cclist="icc $cclist"
- AC_MSG_RESULT([yes]),
- use_icc="no"
- AC_MSG_RESULT([no]))
-
# Checks for programs.
# GCC is chosen last because it is likely to yield less optimized code
AC_LANG(C)
-AC_PROG_CC([$cclist])
+AC_PROG_CC
# C Compiler: Check that it is ANSI C and POSIX-compliant
AM_PROG_CC_STDC
AC_ISC_POSIX
-ACX_PROG_CC_OPTIM
AC_DISABLE_STATIC
#AC_DISABLE_SHARED
AC_PROG_LIBTOOL
@@ -160,17 +137,6 @@
use_gprof="no"
AC_MSG_RESULT([no]))
-# Enable static linking
-AC_MSG_CHECKING([static linking])
-AC_ARG_ENABLE(static,
- [AC_HELP_STRING([--enable-static],
- [Enable static linking \
-(off by default)])],
- use_static="yes"
- AC_MSG_RESULT([yes]),
- use_static="no"
- AC_MSG_RESULT([no]))
-
################# Actions to complete in case of multhreading ################
AC_DEFINE_UNQUOTED(THREADS_NMAX, $n_pthreads,[Maximum number of POSIX threads])
if test "$use_pthreads" = "yes"; then
@@ -205,19 +171,9 @@
# Link with gprof option
if test "$use_gprof" = "yes"; then
- if test "$use_icc" = "yes"; then
- CFLAGS="$CFLAGS -pq"
- else
- CFLAGS="$CFLAGS -pg"
- fi
use_static="no"
fi
-# Static linking option
-if test "$use_static" = "yes"; then
- LDFLAGS="-static -shared-libgcc $LDFLAGS"
-fi
-
# Override automatic CFLAGS and LDFLAGS with those of user
#if test -n "$mycflags"; then
#CFLAGS="$mycflags"